Support » Plugins and Hacks » [Plugin: podPress] Edit Page – Podpress Plugin errors in 8.8.4?

  • Every time I visit the Edit Page for any of the existing pages (with a podcast or not) I see these error messages in the Podpress “window”:

    Warning: Attempt to assign property of non-object in /hermes/web03/b382/pow.dmw/htdocs/mywebsite/wp-content/plugins/podpress/podpress_class.php on line 506

    Warning: Attempt to assign property of non-object in /hermes/web03/b382/pow.dmw/htdocs/mywebsite/wp-content/plugins/podpress/podpress_class.php on line 556

    Warning: Attempt to assign property of non-object in /hermes/web03/b382/pow.dmw/htdocs/mywebsite/wp-content/plugins/podpress/podpress_class.php on line 558

    Warning: Attempt to assign property of non-object in /hermes/web03/b382/pow.dmw/htdocs/mywebsite/wp-content/plugins/podpress/podpress_admin_class.php on line 603

    What in the world happened there…? Everything was just fine until I upgraded to the latest version…

    http://wordpress.org/extend/plugins/podpress/

Viewing 12 replies - 1 through 12 (of 12 total)
  • …until I upgraded to the latest version of WordPress (2.9.1), that is.

    I’ve had the above issue with Podpress 8.8.1 on WP 2.9.1 and after upgrading to 8.8.4 it’s still there…

    Yet on another site, with the same new versions up I get these errors:

    Warning: fsockopen() [function.fsockopen]: unable to connect to http://www.podango.com:80 (Connection refused) in /hermes/web03/b382/pow.dmw/htdocs/mywebsite/wp-content/plugins/podpress/podango-api.php on line 755

    Warning: fwrite(): supplied argument is not a valid stream resource in /hermes/web03/b382/pow.dmw/htdocs/mywebsite/wp-content/plugins/podpress/podango-api.php on line 756

    Warning: fclose(): supplied argument is not a valid stream resource in /hermes/web03/b382/pow.dmw/htdocs/mywebsite/wp-content/plugins/podpress/podango-api.php on line 760

    podpress is totally blowing my feeds by filling them with this:

    <!– podcast_generator=”podPress/8.8″ – maintenance_release=”8.8.4″ –>

    <b>Warning</b>: htmlentities() expects at most 3 parameters, 4 given in <b>/var/www/vhosts/mywebsite.com/httpdocs/programming/wp-content/plugins/podpress/podpress_feed_functions.php</b> on line <b>31</b>

    <copyright> </copyright>

    with it recurring for multiple items besides copyright

    @electricscribe: Thanks for the report! That means that the PHP on your server is lower than 5.2.3 and that I have added the fourth parameter to quick. I’m sure that this problem will be resolved in the next version.

    If you like fix this until the next version then open the file podpress_feed_function.php with a text editor (not MS Word), got to line 31 and remove a comma and the word FALSE:

    old:
    $result = htmlentities($input, ENT_NOQUOTES, get_bloginfo('charset'), FALSE);

    new:
    $result = htmlentities($input, ENT_NOQUOTES, get_bloginfo('charset'));

    @crazyserb:
    the Podango problem:
    The podcast host Podango is since 2008/2009 “[…] currently on vacation […]” as they write on their site and on podcastingnews.com you can read something comparable. it seems to me that this service has ended.
    podPress was/is still designed to use for some additional features the API of the Podango web site but since this service is down there will be warning messages if you try to use the option “Enable Podango Integration:” on the general settings page of podPress. In my opinion this problem appears independently from the podPress version.

    Same problem here:
    [Plugin: podPress] Podango and PodPress

    @crazyserb:
    I have tried to reproduce the warning messages which you have listed in the first post. But until now I had no success and I’m still unsure which condition causes these messages.

    Are these messages only on the “Edit Page”-page? Or on the “Edit Post”-page, too?

    That podpress_feed_function.php – I had the same issue… thanks for the fix. Now the feeds are finally validating. Phew… been losing subscribers because of that.

    As far as the original podpress_class.php error messages, I am getting them on both “Edit Post” and “Edit Page” pages for some reason… the site is on PHP 5.2.2, if that helps at all.

    Never mind, disregard the podpress_class.php error messages… it was due to a bug in an older version of EG-Attachments plugin, so after upgrading that it is all fine and dandy.

    Thanks again for the quick help!

    That you have experienced these messages on both “Edit Post” and “Edit Page” pages is what I had expected.

    But this problem seems to be resolved.?

    Correct. Resolved. Thanks again.

    Hi guys and gals, r.e. the original problem- it’s due to the api being down for podango, to resolve the problem I edited the podango-api.php file by commenting out the block that refers to the downed files, so line 5 to 8 will not be referred to.

    <?php
    
    class PodangoAPI
    {
    	/* var $serviceUrl = 'http://www.podango.com/api/';
    	var $fileUploader = 'http://www.podango.com/podcasts/file_upload.php';
    	var $mediaTrackerURL = 'http://download.podango.com/mediatracker/'; */

    Works great for me, so far.

    @nazimjamil: I have tried your proposition. The editor page is loading faster but the error messages are there and the media uploader is not of course not there. Instead the editor page was loaded (in an iFrame again).

    I don’t think that this a good solution.

    8.8.5 will probably have a clear advice beneath the Podango check box on the “General Options”-page (http://plugins.trac.wordpress.org/ticket/1066).

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: podPress] Edit Page – Podpress Plugin errors in 8.8.4?’ is closed to new replies.