Custom Podpress feeds not found (5 posts)

  1. bstritesky
    Posted 3 years ago #

    I am having issues opening any of my custom feeds. I have created two that don't open:

    The following feed does most of what I'd like the above ones to do, except I don't like the iTunes name of it (but I can't change it unless I change the entire website name): http://embclife.org/sermons/feed/

    I turned off Bulletproof Security and WP Super Cache. In addition, I totally cleared out the .htaccess file, made sure each of these podcast feeds is marked "Active", and then re-saved the custom permalink structure. I have also tried the above links with /?feed=<feedname>, with the same results. There are no directories that are called "feed", either.

    This feed worked properly in my old WP installation, and here's an example: http://embclife.org/audio/feed/embcoldaudio/

    Can you help me figure out why I can't access these feeds? Thanks.


  2. bstritesky
    Posted 3 years ago #

    After doing some testing, it seems that this is because all of my podcast posts are part of a custom post type. When I added a podpress media file to a normal post, then the feed appeared, but only with that one post, and nothing else from my custom post type.

    I have the Podpress settings such that the Podpress section is available for this custom post type (sermons), and from the /sermons/feed link above, that's definitely working.

    How can I get the custom podcast feed to incorporate all of the posts from within my custom post type? Thanks.

  3. bstritesky
    Posted 3 years ago #

    OK, I seem to have solved my problem. I am using the "Types" Custom Post Type plugin to create the "Sermon" post type, and all of the sermons and audio files are attached to posts in that post type.

    However, I needed to add the "Custom Post Type Selector" plugin as well to add the Sermon post type to the WordPress loop--apparently something that the "Types" plugin doesn't do by default.

    I now see my custom podcasts!

  4. bstritesky
    Posted 3 years ago #

    Just a note of follow-up. The "Custom Post Type Selector" plugin was causing PHP warnings to be logged on my pages, probably because it was incorrectly adding my custom post type to the loop.

    I followed the tutorial here to add my custom post type to the loop in my functions.php file, and that works without any PHP warnings.

  5. ntm
    Plugin Author

    Posted 3 years ago #

    I use the Custom Post Type UI plugin to add custom post types to my blog. But it seems to be also necessary to add the code from the post of Justin Tadlock.

    But I have no problem with the additional podPress Feeds and I have no idea why the feed http://embclife.org/feed/embcsermonpodcast is not working. But if you open http://embclife.org/?feed=embcsermonpodcast you will get the error message ERROR: embcsermonpodcast is not a valid feed template. which is a clear sign that this feed has now different slug name or that it is not active or that you have not saved the Permalink settings after creating this feed.
    (the same with http://embclife.org/audio/?feed=embcoldaudio)

    http://embclife.org/sermons/feed/ is probably not working because the option 'has_archive' => TRUE is not TRUE (see http://wordpress.stackexchange.com/questions/13006/nice-rss-feed-urls-for-each-custom-post-type).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic


No tags yet.