Support » Plugins and Hacks » podPress » [Resolved] [Plugin: podPress] broken widgets sitewide

[Resolved] [Plugin: podPress] broken widgets sitewide

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author ntm


    Thank you for this report!

    There is a problem which occurs with and WP 3.3. But it seems that it occurs only if you modify (add a new one, remove one, etc.) your sidebars. That is why I haven’t noticed the problem myself during or after the upgrade.

    However, I have already a pretty good idea of what the source of the problem is. I will report back as soon as I can tell you more.


    Plugin Author ntm


    I will release an update in the next days. But until the next version is ready you may fix this problem by modifying one line in one .js file.
    In the file /wp-content/plugins/podpress/js/jquery/podpress_jquery_ui_widgetssettings.js
    you will find the line (27):

    var podpress_a_widget_id = ui.item.find('a.widget-action').closest('div.widget').attr('id');

    Replace that with:

    var podpress_a_widget_id = ui.item.find('div.widget-inside > form > input.widget-id').val();


    that worked! it’s fixed! Woohoo! thanks!
    I can now drag-and-drop my widgets and it saves them properly!

    That did NOT work for me 🙁

    Any word on that update? I tried the above fix and it did not work for me. Thanks for the help!

    Anything new?

    I am having the same trouble.

    Updated WP to 3.3.1 this morning.. same issue. When I drag either the player widget or the button widget onto a sidebar and refresh the widget page, the widget doesn’t “stick”

    using podpress

    using a multi-site environment. I loaded this plugin on a blank test site and the issue followed. An older site which already had the widget running prior to WP 3.3 is still working.

    update: if i clicked “disable dashboard widget” along with the previously mentioned fix, the changes seam to stick.

    I wish I had found this post 3 hours ago. After spending the entire morning trying to figure out why I can no longer add widgets after upgrading to WordPress 3.3.1 I found that Podpress was the problem. I wasn’t able to create any new Widgets, not even a text widget.

    I have deactivated the plugin and I now have functionality restored to my widgets.

    Same problem, and this poses a big issue for some of my sites … I’m a podcaster and run two different sites that rely in Podpress to distribute my content. Right now, I have to disable the plugin, change my sidebar, and then reactivate the plugin to get it to work.

    An update to fix this problem would be fantastic!

    FINALLY! The fix provided above worked for me! I’ve been deactivating the plugin, then adding widgets, then reactivating the plugin for 2 weeks now! lol

    I have same problem.

    Have you come up with anything yet? It’s been 3 weeks and still no update. Let me know what I need to do if you need a hand.

    This fix worked for me. Thanks!

    Any update on an official fix? Thanks.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] [Plugin: podPress] broken widgets sitewide’ is closed to new replies.
Skip to toolbar