Support » Plugin: podPress » [Plugin: podPress] no enclosures in feed

  • Resolved abemishler


    Is anyone using this version successfully with WP 3.1.1? After upgrading (from what version I don’t remember, though fairly old), my iTunes page no longer lists my podcast episodes and my feed doesn’t have enclosures.

    Am also using feedburner, but I don’t see enclosures there either. All of my posts have a podpress media item attached.

    Really struggling here. Why don’t I have enclosures in my feed?

    Edit: I’m not using any of the widgets, and I don’t actually use podpress to display the media in my post. I rely on podpress to just put media items in the feed.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ntm


    Please, control all settings at the Feed/iTunes Settings page of podPress. If you have upgraded from a version which is older than 8.8.8 then you need to adjust some settings.
    Now, there is a difference between the settings for the usual blog feeds like and the so called podPress Feeds like
    You can modify the preferences for the podcast feed in the podPress Feeds section on the Feed/iTunes Settings page.
    It might also be helpful if you could re-save the Permalink settings.

    Furthermore you could control whether or not the wp_postmeta table of the data base of your blog contains rows where the meta_key is podPressMedia or podPressPostSpecific. Rename them to _podPressMedia and _podPressPostSpecific.
    You can do this by opening the general settings page of podPress and looking at the section System Information. If there values with the old meta_keys then there should be a clear message and a possibility to rename the values.
    This section will also show whether there exists a version conflict or not.

    Maybe I can give you some more hints if I could take a look at the feeds of your blog.


    Hi Tim,

    Thanks for the quick reply. I read that the permalinks should be re-saved and have done that. I use the “month and name” setting.

    The “Feed podcast” where “podcast” is the slug name, is activated (via the checkbox). This is the first one in the accordian-style interface.

    The “current Feed URL” is in the form of as you suggested. And I have updated the “Original Feed” setting in my feedburner account to point to this URL.

    The checkbox:
    “Include only posts with podPress attachments in this Feed” is selected. All of my posts have an attachment, btw. And all of my posts show up – but without an enclosure…

    I don’t see any information about a conflict or podPressMedia or podPressPostSpecific or how to rename them in the General Settings page. This part of your reply is somewhat confusing to me.

    I’d be glad for any pointers you could offer. I’m really at a loss for why this isn’t working anymore:

    Edit: links removed


    Hi Tim,

    Turns out, it was a Feedburner problem, not podPress. I tried to delete the original contents of the post, but ran out of time. There was no “real” problem with podPress. It was all Feedburner.

    For anyone experiencing issues like mine and using podPress combined with Feedburner, edit your “SmartCast” settings to the following:

    Create podcast enclosures from links to: “any rich media file”

    My enclosures are .mp4 video files, however, Feedburner thinks they are MPEG Layer 3 Audio. Having “video files only” selected stopped those files from showing up. What a deal.

    Thanks Tim!

    Plugin Author ntm


    I don’t see any information about a conflict or podPressMedia or podPressPostSpecific or how to rename them in the General Settings page.

    Such information and option are getting only displayed if there is a conflict or a problem. That you can not see something such a message or option is a good sign.

    I’m glad that you could solve the problem.

    Thank you for your detailed reports and explanations!


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: podPress] no enclosures in feed’ is closed to new replies.