WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: podPress] 2 MP3s on a post, itunes only showing one!?

[Resolved] [Plugin: podPress] 2 MP3s on a post, itunes only showing one!?

  • Hi Podpressers!

    Just updated the plugin from 8.8 to 8.8.10.13, a jump I know!
    Its an awesome update and major thanks to the continued support for this plugin.

    Im loving the fact that my podcast i-tunes feed is working, I can subscribe and the mp3s download and they play fine.

    I have found an issue with this plugin that interferes with another plugin.

    The way I found the conflict is that despite my website having 150 odd posts (all in the same category) with 2 MP3s embedded in each post, only ONE post was showing on the i-tunes subscription list.
    I checked that post to see what was so unique and I forgot to add some entries into a plugin Im using on my website. The lack of entries on that particular post means that the feed works.
    I checked and deleting the entries to this plugin on another post, then allows podpress/i-tunes to see the post.

    The plugin Im referring to is: Event Calendar by Alex Tingle. Located here: http://wordpress.org/extend/plugins/event-calendar/

    Although there seems to a cross plugin issue, is there anything podpress support would like to do here? Im happy to supply files/folders for CSS examination or something. I am using 3.1.4 (the current version still available if that helps).

    The issue with which I’m posting today, is that when I have 2 MP3s embedded into 1 post (at the end if that maters), i-tunes is only showing one.
    I spotted a post earlier that mentions that a post that contains more than a few mp3s should have them listed in a singular post, but I have only 2!?
    Is there a fix to this? And can the podcast name for these files be changed from the post name to the Media file Title automatically?

    Many Thanks,
    Rhys.

    http://wordpress.org/extend/plugins/podpress/

Viewing 15 replies - 1 through 15 (of 16 total)
  • I quickly deactivated the Event Calendar plugin (not the widget), and the whole shabang showed up on iTunes. But just the FIRST file on each post, and not the second.

    OK, looks like I’ve jumped the gun here.
    After reading the FAQ of the plugin, it mentions the lack of getting itunes to see 2 MP3s per post, but then talks about using an ATOM feed instead of a RSS2 one.

    I’ve tried an ATOM feed, and all I got was weird characters instead of – or > in itunes. RSS2 was fine.

    Im confused, in short, can this be done or what!?

    Plugin Author ntm

    @ntm

    Posts (entries) in ATOM feed can have multiple attachments/enclosures. But the problem here is iTunes and not the RSS specification. iTunes can process ATOM feeds but it will always show only one of the media files.
    That is why it is not recommendable to attach multiple media files to one post. One exception is if you want to publish an episode in different file types (.mp3, .m4a, .ogg etc.).

    Thanks ntm,
    So your saying that if I put more than one sound file on a post, then iTunes will see both if they are both different type!? I.e one as a mp3 and one as a .m4a!?

    Any comments in the Event Calendar plugin clash?

    Plugin Author ntm

    @ntm

    Any comments in the Event Calendar plugin clash?

    I have installed Event Calendar 3 v3.1.4. I installed it in a WP 3.3.x test blog and it generates on the blog pages and the feeds PHP error messages which make it impossible to view the RSS feeds at all.
    But these particular problems are obviously related to the PHP version on my test server. I installed http://wordpress.org/extend/plugins/event-calendar-3-for-php-53/ afterwards. This version does not trigger the same problems and I could also not reproduce the situation which you described in the first post. But maybe I used different settings.
    Please, post your settings for Show schedule within posts: and
    Show events as blog entries: and tell me whether the posts which were not in the feeds at first were events.

    Tim

    Show schedule within posts: hide schedule
    Show events as blog entries: Keep events separate

    What’s interesting is that despite the first setting as hide schedule, it does show on blog home in the auto generated excerpt. (Even if I specify some text as a forced excerpt, this calendar entry text still shows!?)

    My blog is located at http://www.bethel-gorseinon.org.uk
    You will see the issue in the posts located at the middle column despite the show schedule within posts turned off. When you click a post, it doesn’t show on the post page but does here!? I’m dying to did out how to turn that off, as I’m no code expert.

    Oh and yes, as you said, posts that didn’t show in the feed were first as events. As soon as I deleted the event times from the post, the mp3 then showed in the feed.
    Readding the calendar timing and it disappears from the feed.

    Thanks for your help.

    Plugin Author ntm

    @ntm

    Thanks for posting your settings.

    As I understand it, Show events as blog entries: Keep events separate means that posts which are marked as an event do not appear on the main blog page and not in the feeds. That is how it appears to be in my blog. If you “keep events separate” then these posts are probably only reachable via the event calendar or special pages.
    However this is how this plugin works and is no unwanted interference with podPress. You can make event posts visible on the main blog and in the feeds by changing this setting to “Events are Normal Posts”.
    It seems that you don’t have to remove the events from posts.

    What’s interesting is that despite the first setting as hide schedule, it does show on blog home in the auto generated excerpt.

    I can observe this too. The excerpts show a placeholder for the formatted event date.
    This is an issue which is related to the way the vent calendar plugin works. This maybe a bug in Event Calendar 3 and also Event Calendar 3 for PHP 5.3.
    I added the tags of these plugins to this thread.

    Plugin Author ntm

    @ntm

    If you are not afraid of modifying the code of the event calendar plugin a little bit, you can make the plugin hide the events also in excerpts.

    Edit the file eventcalendar3.php lines 592-596 (the file of the Event Calendar 3 for PHP 5.3 has some more lines and you can find the same code a little bit lower.)
    old:

    if(!$ec3->hide_event_box)
        add_filter('the_content','ec3_filter_the_content',20);
    
      remove_filter('get_the_excerpt', 'wp_trim_excerpt');
      add_filter('get_the_excerpt', 'ec3_get_the_excerpt');

    new:

    if(!$ec3->hide_event_box) {
        add_filter('the_content','ec3_filter_the_content',20);
    
      remove_filter('get_the_excerpt', 'wp_trim_excerpt');
      add_filter('get_the_excerpt', 'ec3_get_the_excerpt');}

    By adding the curly brackets you include the lines which are related to excerpt filters into the if-condition and both lines will be executed only if hide_event_box is FALSE or in other words: if you chose “Show Schedule” (within posts).

    The hack worked! Cheers mate!
    Ive been using your plugin for years and this hack and spurred on to a donation soon.

    5* Support!!!

    I just noticed. Any episodes listed in i-tunes that haven’t been downloaded are showing as 0:01 as the episode length.

    As soon as they are downloaded, they length shows correctly.

    Is this a bug that has been noticed!?

    Plugin Author ntm

    @ntm

    Is this a bug that has been noticed!?

    No, it is most likely no bug. If you do not declare the duration for a media file (in the podPress box below the post editor) then iTunes don’t know what the duration of a media file is – until it is downloaded. Until the download iTunes takes all information from the feed and not from the media files itself. That is why it is a good idea to fill in as much meta information as possible. podPress has a Auto Detection for the duration value. Try this and if it can’t retrieve the duration then insert it in the format hh:mm:ss.
    One further reason to insert the correct duration value is that the preview player on the iTunes page of your podcast will not work.

    Furthermore it is important to enter the file size value in the podPress form.

    (Both values are missing for instance for the podcast of October 7. http://www.bethel-gorseinon.org.uk/wordpress/?p=1558.)

    Awesome. As you suggested, hitting ‘auto detect’ in the file duration in the meta details worked into the itunes feed.
    Would be good if that was done automatically, maybe when the post is saved as draft or published. But just a feature request.
    Glad thats working with little work for the post author.

    One last support request:
    Is it possible to change the episode name from the post name to the Media File Title (the one specified manually by the user when embedding a file in a post!?)

    Currently each episode by named by the post, but I would rather have the episode named by the contact of the mp3 rather than the heading of the post in which it is contained.

    Thanks ntm! You da man!

    Plugin Author ntm

    @ntm

    Would be good if that was done automatically, maybe when the post is saved as draft or published.

    Yes it would be good. But the auto detection may take in some cases more than a few seconds. Sometimes the process ends with no result. In such cases the author would noticed that only after saving and viewing the post on the front page and had to head to the editor page once more to adjust the value manually.
    That is why I will not change this part of the plugin.

    Is it possible to change the episode name from the post name to the Media File Title (the one specified manually by the user when embedding a file in a post!?)

    I think I will implement a function which will use the Media File Title as the post title if the Media File Title input field is not and the post title input field is empty (during the publishing process).

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] [Plugin: podPress] 2 MP3s on a post, itunes only showing one!?’ is closed to new replies.