Support » Plugins and Hacks » [Plugin: Podcasting] MP3s not saved in Podcast RSS Feed

  • Hi,

    I’ve been working on a new website that will include a wordpress blog with podcasting plugin (hopefully anyway).

    It works fine on my development server (Vista, WP 2.5) but when I upload to the hosted Linux server (which will be the public one eventually and is running WP 2.6) the audio files appear in the posts in the blog (i.e. in the flash player, which works ok) but the podcast feed is empty. It’s really strange.

    Also, on the working server when I go back to the post the podcast file’s URL is still in the “Podcasting” section beneath where you type the post. On the non-working server it appears to have “forgotten” it.

    Can anyone help?

Viewing 15 replies - 1 through 15 (of 77 total)
  • It seems like this problem only happens with 2.6. I downgraded to WP 2.5 on the server and everything seems to work! Nasty. If it’s a compatibility problem I guess I might have to switch to podPress 🙁

    Are you using the latest Podcasting beta version (beta 5)? I had a few people who experienced this issue that had their problem resolved with the latest beta.

    If you are on the latest beta, can you send me a database dump (ron at cavemonkey50 dot com)? I want to try and find the source of this issue.

    I’m having the exact same problem as beano, and I’m running beta 5.

    My post:
    http://motionographer.com/2008/09/08/podcast-episode-01-this-way-up/

    My podcast feed:
    http://motionographer.com/feed/podcast/

    Just like beano’s experience above, things work on my dev server, but not on my live server. And in the Podcasting field of the post, the URL is empty.

    Thanks for your help, cavemonkey!

    juicysauce,

    Delete all enclosures from the troublesome post(s), and readd the files. This should correct the issue.

    I’m assuming you were running an older version before upgrading? If not, and you’ve always been running the latest 2.0 beta, please let me know. There may be another bug not addressed in the current version.

    Thanks so much for your response. I’m not exactly sure what deleting enclosures involved, but as a test, I created a new post with no content. I then uploaded an mp3 and pasted its URL into the Podcasting file input. When I hit Save, the page reloaded, but the Podcasting fields had reset themselves, just as beano described in his initial post.

    Hi cavemonkey50,

    I’m having the same problem for a while: whenever I try to add an enclosure, as soon as I save the post all podcasting fields come reset. I was using 1.65, and after reading this, I upgraded to 2.0 beta 5 (some hot stuff in there, thanks a lot), but no luck.

    My current feed is http://www.submusica.com/feed/podcast, and it’s working fine — the problem seems to be on adding enclosures.

    I’m trying to observe in deep detail what’s happening and will keep on watching this thread.

    Thanks a lot for your awesome dedication. If only half of WP plugins were elegant like this… 🙂

    Hello juicysauce and dudup,

    What’s exactly happening after saving the post? Is the enclosure disappearing completely or is remaining, just missing some details? If completely disappearing, how are you adding files? Are you using the full URL to the file? If you are, can you provide an example URL so I can test adding that file to my installation?

    It’s disappearing completely for me. I uploaded the audio file through WP and then pasted the full URL in the Podcasting file field:

    [audio src="http://motionographer.com/wp-content/uploads/2008/09/motionographer01-this-way-up.mp3" /]

    I was able to do this on my local installation of WP and everything worked great. For some reason on my live server, it’s not working.

    I just did some testing and that URL works fine on several different installs. Perhaps your server is not recognizing mp3s correctly. Try adding this line to your .htaccess file (found in the root directory of your WordPress install):

    AddType audio/mpeg mp3

    cavemonkey50,

    It disappears completely after I save the article.

    It seems to me that the bug we’re facing is related to this specific, because everything previously uploaded is working fine, as you can see on my feed.

    As soon as I get to work, I’ll try to disable plugins and run more specific tests.

    Thanks a lot for your support

    Adding “AddType audio/mpeg mp3” to my .htaccess didn’t seem to help. I did install the plugin on another WP blog and got it to work successfully. So strange…

    Let us know what you find, dudup. Thanks!

    I’ve discovered a workaround that *kinda* fixes things: Add a new Custom Field for the post, using “enclosure” for type. Paste the URL to your mp3 in the Value field.

    I also re-pasted the URL in the Podcasting field. This time, when I saved my post, the URL stayed in the Podcasting field. All the other Podcasting values (e.g. keywords, author, length, etc.) were gone, but at least the URL remained.

    When I check my podcast feed, I now see the post that contains the podcast. I don’t see the podcast (i.e. the mp3 file) itself, though…

    (Sorry for rambling. I’m sure you guys know much more about this than me, but in the hopes that I might say something useful, I’m writing all my discoveries here.)

    I was looking through my wp_postmeta table in the database and I found that for some reason it looks like WP stopped creating enclosure meta data right around April, which is when I upgraded to WP 2.5, I believe.

    I don’t know, just another clue. 🙂

    It appears I have the identical problem. I am running WordPress 2.6, with all but the Podcasting plugin disabled for testing purposes. I specify a full URL to a MP3 file and add it in the Podcast panel. When I save the post, it disappears and no enclosure meta value exists for the post in the database. I have tried both 1.65 and 2.0 beta 5 with no luck.

    Thanks for the feedback, guys. It appears the WordPress enclosure function (which I take advantage) seems to be extremely weird since 2.6. I’m going to look into more tonight and see what can be done.

Viewing 15 replies - 1 through 15 (of 77 total)
  • The topic ‘[Plugin: Podcasting] MP3s not saved in Podcast RSS Feed’ is closed to new replies.