[resolved] Apostrophes being escaped in several fields (3 posts)

  1. Kim Parsell
    WP Mom
    Posted 4 years ago #

    First, let me say I love this plugin - very easy way to get things started!

    I noticed that when I create a new plugin, apostrophes in the name, description, author, and license fields are being escaped. Instead of the title being Can't Do This, it comes up as Can\'t Do This in both the editor field and the dropdown to select which plugin to edit, as well as showing up that way on the plugins page.

    I discovered this on my local server, so I also tested it on my shared hosting with the same result. Here are the specs for both servers:

    Local server (XAMPP 1.7.3):
    + Apache 2.2.14 (IPV6 enabled)
    + MySQL 5.1.41 (Community Server) with PBXT engine 1.0.09-rc
    + PHP 5.3.1 (PEAR, Mail_Mime, MDB2, Zend)
    + All magic_quotes_* are off

    Shared hosting server:
    + Apache 2.2.22
    + MySQL 5.5.23
    + PHP 5.2.17 (Zend)
    + All magic_quotes_* are off

    Other than this issue, it works like a charm for me. Thanks for releasing it! :)


  2. Samuel Wood (Otto)
    WordPress.org Tech Dude
    Plugin Author

    Posted 4 years ago #

    Stupid magic quote emulation.

    Fixed in 1.1.

  3. Kim Parsell
    WP Mom
    Posted 4 years ago #

    Tested and it fixes the problem for me as well. Thanks for taking care of it so quickly! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Pluginception
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic