Support » Plugin: Picasa Album Uploader » [Plugin: Picsa Album Uploader] No files provided for upload

  • Resolved rbredow


    This is a great idea for a plugin. However, for some reason I can’t get Picasa to actually send the photos. Everything connects and Picasa generates it’s little status window that shows the selected images, I see the thumbnail in the browser, but when you’d expect it to be done, I get the following error in the browser:

    Error: No files provided for upload

    I’ve tried this with one photo and with several and got similar results. Permalinks are on.

    I’m running WordPress 3.03 and Picasa (for Mac). My browser is Google Chrome (9.0.597.19 beta). And here is the log output in case there’s a hint in there:

    2010-12-26 15:40:54 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-26 15:41:03 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-26 15:41:03 Parsing request picasa_album_uploader/minibrowser
    2010-12-26 15:41:03 Request will be handled by plugin
    2010-12-26 15:41:03 Using plugin supplied template
    2010-12-26 15:41:08 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-26 15:41:08 Parsing request picasa_album_uploader/upload
    2010-12-26 15:41:08 Request will be handled by plugin
    2010-12-26 15:41:08 Picasa did not upload any files
    2010-12-26 15:41:09 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-26 15:41:09 Parsing request picasa_album_uploader/result
    2010-12-26 15:41:09 Request will be handled by plugin
    2010-12-26 15:44:08 Permalink structure: /%year%/%monthnum%/%postname%/

    Thanks in advance for any help and thanks for a great free plugin. I only hope I can make it work!


    P.S. You might get a few more people finding your plugin if you change the official name in the plugin repository from Picsa Album Uploader to Picasa Album Uploader.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Ken Brucker


    Doh! I’ll have to see about changing that displayed name! Thanks for catching it.

    I’m running the same version of Picasa. It’s really hard to tell what (and why) Picasa is doing. It uses a minibrowser and is very hard to get debug data out of it. I am working on some changes to improve the debug, but this one might remain troublesome since Picasa isn’t sending the right data.

    Even worse, I was just looking at the Picasa API information and Google has deprecated the API! 🙁

    Thanks for the quick response.

    I’m running the same version of Picasa.

    Just out of curiosity, do you see the same problem I’m seeing?

    Thanks again,


    Plugin Author Ken Brucker


    I’m not able to recreate it so far. I’ve been looking through the code to see where I can add more logging to determine what is happening.

    Plugin Author Ken Brucker


    Still haven’t been able to recreate a failure. I have updated to v0.4.1 that includes more debug that might give some additional diagnostics to figure this out.

    If you would give the new version a try I’d appreciate it.

    Thanks for the update. I re-downloaded the plugin (and re-installed the wordpress button in Picasa just in case). I had the same symptoms with the upload. I’m running 10.6.5 Mac OSX if that helps. Here is the log file:

    2010-12-31 23:32:39 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-31 23:32:44 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-31 23:32:44 Parsing request 'picasa_album_uploader/minibrowser'
    2010-12-31 23:32:44 Request will be handled by plugin
    2010-12-31 23:32:44 Generating Minibrowser content
    2010-12-31 23:32:44 Form Setup: http://localhost:54216/98936c627389ac032d6f1da88e90720c/image/b4d122b1d8f0d721.jpg
    2010-12-31 23:32:44 Using plugin supplied template
    2010-12-31 23:32:47 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-31 23:32:47 Parsing request '2008/03/termites'
    2010-12-31 23:32:47 Request is not for plugin: '2008/03/termites'
    2010-12-31 23:32:47 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-31 23:32:47 Parsing request 'picasa_album_uploader/upload'
    2010-12-31 23:32:47 Request will be handled by plugin
    2010-12-31 23:32:47 Upload request received
    2010-12-31 23:32:47 Picasa did not upload any files
    2010-12-31 23:32:48 Permalink structure: /%year%/%monthnum%/%postname%/
    2010-12-31 23:32:48 Parsing request 'picasa_album_uploader/result'
    2010-12-31 23:32:48 Request will be handled by plugin
    2010-12-31 23:32:55 Permalink structure: /%year%/%monthnum%/%postname%/

    By the way, that localhost link (in the Form setup: line) actually works and points to the hires image I was intending to upload.

    Thanks again and good luck!


    Plugin Author Ken Brucker


    What other plugins do you have installed? I’m thinking something else is mucking with the incoming data before it gets to my plugin.

    Great question. I just tried de-activating all the other plugins but I got exactly the same results (and the log looked the same as well). I had a hunch maybe it was something in my .htaccess file so I cleaned that up as well. I even tried a generic looking .htaccess file that sends everything to WP for clean URLs:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    But I got the same results so far. I’ll keep thinking about additional testing that might provide any useful data. Thanks again for all your help.


    I had one more idea that perhaps some of the functions in my theme might be the conflict. So I changed to the WordPress default and de-activated all the other plugins again but got the same results. Not the best news. Must be something specific to my configuration.

    On a hunch, I tested with another blog on another hosting provider and it worked perfectly the first time. I also tried it on a second blog on my hosting provider I’ve been testing this whole time and it fails with the same error. So it definitely points to something specific on that box. I checked the obvious things like the php upload size and it’s set plenty high. The failing server is running Ubuntu 8.04.4 LTS and the working one is running something older that’s outside of my control.

    I’ll let you know if I come across anything else helpful.


    Plugin Author Ken Brucker


    This is an interesting bit of evidence. What about differences in the Apache/PHP combo in use between these servers?

    If you try uploading the same media file on the failing server using the normal WP interfaces, does it work?

    Anything show up in the log or error log on the failing server?

    It’s alive!

    There are many differences between the two servers (apache2 vs apache1, different versions of php5), but it looks like the most important difference was suhosin installed on the offending server. Suhosin was limiting the variable name length. Here is the error I found in the the apache log (courtesy of suhosin):

    ALERT - configured request variable name length limit exceeded - dropped variable 'http://localhost:51134/b921a58ec2806ab82f5399515fba226e/image/b0f008e85a4fa153_jpg?size=1024'

    By increasing the length of the variable names in the suhosin configuration it worked: = 512
    suhosin.request.max_varname_length = 512

    I also see this warning but it doesn’t appear to prevent the plugin from working:

    PHP Warning: Missing argument 2 for picasa_album_uploader::add_body_class() in /www/ on line 242

    Thanks a lot for all your help. Great plugin. Now I’m off to give it a 5 star rating. 🙂


    Plugin Author Ken Brucker


    Great news Rob! Much appreciate the perseverance!

    This is quite likely the reason some others have been having difficulties with the plugin. Seems like a relatively safe setting would be a max name length value of 128. The string provided is 93 characters. I’ll update the error message to point at this possible solution.

    Regarding the 2nd warning, I see I’m getting the same warning in my logs. I’ll look into it.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Plugin: Picsa Album Uploader] No files provided for upload’ is closed to new replies.