Support » Plugins » [Plugin: Picsa Album Uploader] I have the plugin and the button downloads but…

  • The button won’t install on Picasa 3.6 for Mac. I have verified that the button has installed in ~/Library/Application Support/Google/Picasa3/buttons.

    Any idea what’s wrong?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Sorry for late response… Very busy on my end.

    This sounds like a problem a few others have seen and I haven’t figured out what the problem is yet. I’m going to put some better diagnostic logging into the plugin to get an idea of what is happening. I haven’t been able to reproduce this myself so it’s hard to determine what is going wrong.

    I’ll work on having some updates in a week or so that can be tested.

    Based on a comment from another user, the problem could be related to the use of default permalinks. I’m going to debug that problem.

    To determine if this might be the same problem, could you reply with the permalink structure you are using?

    I have tried all the permalink settings in WP 2.9.2 and none worked with downloading the button and installing it in Picasa 3.6. I don’t get a pbz file at all. When I try to hit the URL directly for the pbz file it gives me a 404 error. Any other news on this problem?

    Not sure why the other permalink settings don’t work. I can confirm that the default setting is a problem. I’m researching how to best handle that setting as the method I’m using right now appears to rely on the rewrite rules used for the permalink options. I don’t have a generic solution yet.

    What other plugins do you have installed? There was a problem with one that I had to apply a workaround for. Can’t recall it off the top of my head right now.

    Hi Draca,

    Here is what I did.

    – Upgraded a fresh install (installed some time ago) to the latest 2.9.2.
    – Installed the AbsolutePrivacy plugin (http://wordpress.org/extend/plugins/absolute-privacy/) and activated it.
    – Installed clyang version of the Picasa uploader (his worked up to the point of adding pictures. I could never get any pictures recognized as being sent to the server. Did some more searching and found your plugin.
    – Deleted all the files from clyang’s install
    – Installed your plugin – couldn’t get the pbz file
    – Disabled AbsolutePrivacy – didn’t work
    – Enabled AbsolutePricacy again
    – Saw the thread about Permalinks and tried each built in option – didn’t work
    – Tried hitting the pbz URL directly with the browser and got the 404 error

    That is all I did up to this point. Let me know if you need any other information.

    I’m working on some updates as I now have a handle on how the links should be crafted when permalinks are not present. I’ll also be adding more debug/logging to hopefully be able to isolate problems like these better.

    There’s also a bit of logic change I’m making that might help this problem. I’ll post when I have the new version available.

    I was having this same problem (default permalinks setting) I changed that setting to Numeric and the button shows up.

    thanks

    I have the new version available that adds better debugging and enforces the permalink requirement. If the problem persists with the new version I’d like to see a copy of the debugging log that can be enabled from the Admin -> media settings.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Picsa Album Uploader] I have the plugin and the button downloads but…’ is closed to new replies.