Support » Plugin: Picasa Album Uploader » [Plugin: Picasa Album Uploader] Help – this killed my admin site

  • Resolved darrinstern

    (@darrinstern)


    HELP!

    I am getting the following errors on my site not that I have installed this plug in:

    This is the error with the plug in folder removed from my site:

    Fatal error: out of dynamic memory in yy_create_buffer() in /homepages/9/d152541188/htdocs/chitown/wp-admin/includes/admin.php on line 25

    The follow in the error I get when I put the folder back:
    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /homepages/9/d152541188/htdocs/chitown/wp-content/plugins/picasa-album-uploader/picasa-album-uploader.php on line 303

    Please help me get my site back!

    Darrin

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Ken Brucker

    (@draca)

    My first guess is that you are running an older PHP version.

    I found a post with information on the yy_create_buffer() error.

    For the 2nd issue, PHP appears to not be recognizing the ‘private’ token before a function which implies you are running something earlier than PHP5. From what I can tell PHP5 introduced the ‘private’ token.

    I’ll make a note in my plugin docs that it requires PHP5.

    I will look up the PHP my host is offering and post it soon. Can you help me fix my site? How do I get access again to my back end?

    Plugin Author Ken Brucker

    (@draca)

    If you’ve removed my plugin from the plugin directory then my plugin isn’t going to be causing yy_create_buffer() error. It appears the PHP process is running out of memory.

    According to the post I referenced regarding the yy_create_buffer() error, you could try setting the PHP memory_limit to -1 in php.ini or .htaccess, or upgrading the PHP version. I’ve never seen the error myself.

    The other possibility based on what others have done is that this relates to a BSD bug impacting PHP 5.2 and earlier. See here and here. These links provide an alternate possible solution. After reading these last two links, I’d try this fix first.

    Plugin Author Ken Brucker

    (@draca)

    One more thing…

    You can check your PHP version, very easily. Create a new file on your server my_phpinfo.php with this content:

    <?php phpinfo(); ?>

    Open this file in your browser and you should get a long page about your PHP config. This will also give you an easy way to confirm that any setting changes you make to the PHP configuration are taking effect.

    After you are done with the file, remove it from your server.

    Thanks,

    My site has cleared and it has been removed and all is back to normal.

    If it helps you there is the my_phpinfo:

    PHP Version 5.2.17

    System Linux infong 2.4 #1 SMP Thu Nov 25 01:59:22 UTC 2010 i686 GNU/Linux
    Build Date Jan 11 2011 10:21:50
    Configure Command ‘../configure’ ‘–program-suffix=5’ ‘–with-pear=/usr/lib/php5’ ‘–with-config-file-path=/usr/lib/php5’ ‘–with-libxml-dir’ ‘–with-mysqli’ ‘–with-kerberos’ ‘–with-imap-ssl’ ‘–enable-soap’ ‘–with-xsl’ ‘–enable-mbstring=all’ ‘–with-curl’ ‘–with-mcrypt’ ‘–with-gd’ ‘–with-pdo-mysql’ ‘–with-freetype-dir’ ‘–with-libxml-dir’ ‘–with-mysql’ ‘–with-zlib’ ‘–enable-debug=no’ ‘–enable-safe-mode=no’ ‘–enable-discard-path=no’ ‘–with-png-dir’ ‘–enable-track-vars’ ‘–with-db’ ‘–with-gdbm’ ‘–enable-force-cgi-redirect’ ‘–with-ttf’ ‘–enable-ftp’ ‘–enable-dbase’ ‘–enable-memory-limit’ ‘–enable-calendar’ ‘–enable-wddx’ ‘–with-jpeg-dir=/usr/src/kundenserver/jpeg-6b’ ‘–enable-bcmath’ ‘–enable-gd-imgstrttf’ ‘–enable-shmop’ ‘–enable-mhash’ ‘–with-mhash’ ‘–with-openssl’ ‘–enable-xslt’ ‘–with-xslt-sablot’ ‘–with-dom’ ‘–with-dom-xslt’ ‘–with-dom-exslt’ ‘–with-imap’ ‘–with-iconv’ ‘–with-bz2’ ‘–with-gettext’ ‘–enable-exif’ ‘–with-idn’ ‘–with-sqlite’ ‘–enable-sqlite-utf8’ ‘–enable-zip’ ‘–with-tidy’ ‘–enable-gd-native-ttf’
    Server API CGI
    Virtual Directory Support disabled
    Configuration File (php.ini) Path /usr/lib/php5
    Loaded Configuration File /usr/lib/php5/php.ini
    Scan this dir for additional .ini files (none)
    additional .ini files parsed (none)
    PHP API 20041225
    PHP Extension 20060613
    Zend Extension 220060519
    Debug Build no
    Thread Safety disabled
    Zend Memory Manager enabled
    IPv6 Support enabled
    Registered PHP Streams https, ftps, compress.zlib, compress.bzip2, php, file, data, http, ftp, zip
    Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
    Registered Stream Filters zlib.*, bzip2.*, convert.iconv.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: Picasa Album Uploader] Help – this killed my admin site’ is closed to new replies.