Support » Plugin: Picasa Album Uploader » [Plugin: Picasa Album Uploader] Empty RSS feed from Picasa; unable to build minibrowser form

  • 2011-02-14 13:18:09 Permalink structure: /index.php/archives/%post_id%
    2011-02-14 13:18:09 Parsing request ‘picasa_album_uploader/minibrowser’
    2011-02-14 13:18:09 Request will be handled by plugin
    2011-02-14 13:18:09 Generating Minibrowser content
    2011-02-14 13:18:09 Empty RSS feed from Picasa; unable to build minibrowser form.
    2011-02-14 13:18:09 Using plugin supplied template

Viewing 9 replies - 1 through 9 (of 9 total)
  • Any takers? The plugin installed correctly, the button installed correctly, I select one or more pictures and click on the button and it asks me for my login info. The prior version of the plugin, at that point, told me that there were no pictures to upload. I then upgraded the plugin and reinstalled the button, now, everything happens pretty much the same, except that I don’t get the “no pictures” message, but I get a 500 error. So I turned no the trace and the above are the relevant lines… any idea?

    Plugin Author Ken


    Have had family emergency this week. Have a look at this thread for a possible solution:

    Plugin Author Ken


    By the way, there should be some additional header information above the trace lines if you are running latest version. Please attach those as well.

    Ok, I am attaching the full trace. WordPress is version 3.0.5, client is IE8 running on Windows 7 64 bit, and Picasa 3.8.0
    I had already seen the other thread, but I am not using that plugin, and none of the other suggestions seemed to make a difference. BTW, one thing that used to cause trouble with some other plugin (and maybe in play here) was that I run my wp under a directory, so my URL looks like

    2011-02-16 20:46:45 Permalink structure: /index.php/archives/%post_id%
    2011-02-16 20:47:10 Permalink structure: /index.php/archives/%post_id%
    2011-02-16 20:47:10 Parsing request ‘picasa_album_uploader/minibrowser’
    2011-02-16 20:47:10 Request will be handled by plugin
    2011-02-16 20:47:10 Generating Minibrowser content
    2011-02-16 20:47:10 Redirecting minibrowser request to login
    2011-02-16 20:47:10 Using plugin supplied template
    2011-02-16 20:47:23 Permalink structure: /index.php/archives/%post_id%
    2011-02-16 20:47:23 Parsing request ‘picasa_album_uploader/minibrowser’
    2011-02-16 20:47:23 Request will be handled by plugin
    2011-02-16 20:47:23 Generating Minibrowser content
    2011-02-16 20:47:23 Empty RSS feed from Picasa; unable to build minibrowser form.
    2011-02-16 20:47:23 Using plugin supplied template
    2011-02-16 20:47:35 Permalink structure: /index.php/archives/%post_id%

    Plugin Author Ken


    Any errors in the server logs?

    I strongly suspect that something is removing the elements of the RSS feed with the long variable names before it makes it to wordpress. This is how Picasa supplies the data to the host and Google has deprecated the interface so I don’t expect them to make any improvements to it unfortunately.

    I run my test environment in an even more complicated directory structure so doubt that has an impact in this situation.

    And apologies, I did some quick checking and I see the updated debug I put in is only in the trunk right now and hasn’t been released.

    I am having the same problem, with the same error messages. My webserver is not logging any errors other than the “Empty RSS feed from Picasa; unable to build minibrowser form.” error from picasa-album-uploader.

    I have checked for the suhosin plugin or indeed anything that would imply the variable names have been truncated – nothing. I don’t know how to re-create the picasa RSS feed to see if the problem is indeed at Picasa or the server.

    This is my first attempt to install this plugin so I don’t know if previous versions would have worked with my setup.

    Plugin Author Ken


    When the RSS feed isn’t available it’s really hard to diagnose why. All the debugging I’ve done to date on the problem indicates that WP does not see the values sent by Picasa. Picasa is probably sending the values and something between Picasa and WP is ripping them out. I’ve been thinking about building a test into the install process to confirm that long variables can be received properly from Picasa.

    The client side portion of this is entirely controlled by Picasa. You could try running with an IP traffic monitor to locate the packets being sent by Picasa… Yeah, real pain to debug this… The documentation from Google is really thin. It’s possible that Picasa doesn’t like something in the config and it’s failing to generate the proper request, which is where a traffic monitor comes in to the debug picture.

    As I have brainstorms I make attempts at improving diagnosability. This is an area that’s been hard to sort out since the only time I’ve been able to recreate this failure is when I restrict the variable name lengths that get delivered to the server code.



    Same issue occurring here, I guess there’s no resolution?

    Plugin Author Ken


    Lozkane, with the data I have, I’m unable to locate an issue outside what’s already been described. The latest version of the plugin (v0.7) does include a test when debug logs are enabled to check for the ability to receive long variable names.

    Please upgrade the plugin to at least v0.7 and enable the debug log from Media Settings. Try uploading from Picasa again and post the log results. You will need to refresh the settings page to see the log content.

    ps. Just getting back from vacation…

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: Picasa Album Uploader] Empty RSS feed from Picasa; unable to build minibrowser form’ is closed to new replies.