Support » Plugins » [Plugin: PHPBB Single Sign On] Can’t Auth Mode – Option Selected Doesn’t Save

  • I can’t get Auth Mode to go “OK”

    I’ve been selecting “wpbb” as the second path on the options page but when I save it, it keeps coming back to Apache.

    I’m using WordPress 2.9.1 and the latest version of PHPBB Single Sign On.

    Please help!

Viewing 15 replies - 1 through 15 (of 61 total)
  • See if this works:
    Go into the phpBB admin panel (ACP). Find ‘Client Communication’ on the left, and click on ‘Authentication’. Select ‘wpBB’ as the authentication method from the dropdown and click ‘submit’.

    Also, if ever need to revert the setting and have access to your forum’s database, try this:

    http://www.phpbb.com/community/viewtopic.php?f=71&t=1623385#p9756775

    i’m having the same problem too. same versions (wp 2.9.1) and the latest version of single sign on.

    i select wpbb as the second path but when saving, it reverts back to Apache.

    When i select wpBB via the phpBB admin panel (ACP), I can view the forum, but when I try to login, I get this error:

    ‘Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 75 bytes) in /home/domain/public_html/forum/includes/utf/utf_tools.php on line 1828’

    I’ve uninstalled and reinstalled but still have the same problem 🙁

    Hello,

    I have the same Problem…..can´t change to wbpp.

    Have someone a solution for this and can tell me how i make it to work?

    I hope for help, please.

    Thanks.

    Sebi

    Hi all,
    The issue you’re having has to do with the fact that the plugin assumes your phpBB tables are located in the same database as your wordpress tables. If you’re phpBB database is located separately from wordpress database (like mine is), then the plugin’s query to update the phpBB’s authentication won’t work. (and thus the wordpress options page won’t “save” or say “ok” for the ‘auth’…)

    Have no fear. There is a solution. You can change the authentication manually in two ways. First, from your forum’s Admin Ctrl Panel (ACP), you can find Client Communication –> Authentication, and choose wpbb from the drop down menu (it will be an option after you move the auth_wpbb file into the ‘{forum root}/includes/auth’ directory). Alternatively, you can run this query on your forum’s database –> UPDATE phpbb_config SET config_value = ‘wpbb’ WHERE config_name = ‘auth_method’

    In both cases, you have to understand that since the plugin does not understand your forum is in a separate database, it will not be able to “save” or indicate “ok” in the plugins’ options page in wordpress. But that’s ok. The important step was to set forum’s authentication mode, which is already done. So now it should work.

    To summarize, here’s a basic outline of how to make this thing work (assuming you’re starting from fresh wordpress and phpBB installations):

    1. install the plugin and activate in wordpress.
    2. click on “install files in phpbb” – after clicking this, i would check to see that the two files were copied to the forum’s directory correctly. there’s only two files that need to be moved over. a) /root/common.php (which replaces the forum’s common.php) and b) auth_wpbb (described above)
    2b. click on save changes in wordpress to make sure file path for the forum is right, e.g. “forum/”
    3. change phpbb authentication mode (described above)
    4. that’s it.

    That is exactly, what i did.

    But in wordpress the option wpbb is not getting saved.

    In the php forum the wpbb authentification is set.

    But what isn´t correct….is it all done like described.

    And the two files are on the right place…..

    I don´t know what to do now.

    Sorry, me again.

    Now i installed the php forum database in the same database like wordpress.

    Now, the options fare all OK.

    But now i have the problem, that my forum is blank

    http://www.starsontv.com/community/

    What is now the problem?

    Please help.

    Sebi

    Brian.Pan

    you mention

    2. click on “install files in phpbb” – after clicking this,

      i would check to see that the two files were copied to the forum’s directory

    correctly. there’s only two files that need to be moved over. a) /root/common.php (which replaces the forum’s common.php) and b) auth_wpbb (described above)
    2b. click on save changes in wordpress to make sure file path for the forum is right, e.g. “forum/”
    3. change phpbb authentication mode (described above)
    4. that’s it.

    I moved the auth_wpbb to my auth directory in my phpbb3 because they’re on separate databases as you mention and was able to select wbpp in my client communication area under authenication

    you mention to check for 2 files in the forums directory… is that suppose to be in the phpbb3 directory if so I only have the auth_wpbb.php that I manually moved; no other files copied over when I hit install files on php BB. I do have files that was copied in the WP directory which would look like this

    /root/forum/common.php
    and /root/forum/includes/auth/auth_wpbb.php

    so far I have all o.k accept for the auth mode does that mean all systems go for me?? how can I test this plugin??

    Reccomended Current OK ?
    Files
    auth_wpbb.php 0.6 0.6 OK
    common.php 0.5.3 0.5.3 OK
    common.orig.php – 0 OK
    Configurations
    Auth Mode wpbb Error
    Wordpress Path Variable forum/ OK

    Thanks for the assistances everybody! I’m still wet behind the ears but not for long if I keep this up 🙂

    L2Gx The Eraser
    http://www.liv2game.com

    Sorry, me again.

    Now i installed the php forum database in the same database like wordpress.

    Now, the options fare all OK.

    But now i have the problem, that my forum is blank

    http://www.starsontv.com/community/

    What is now the problem?

    Please help.

    Sebi

    I was able to set the auth_method but don’t know how to test it. I registered a user from phpBB and when I logged in, nothing happened on WP’s side. And when I tried the opposite, nothing happened as well.

    Live2Game: As you might have discovered by now, I think everything should be working for you. You should now have the ability to have users login into the forum and be able to make comments on your wordpress site under the same login; create users in the forum – which will automatically create accounts in wordpress (and vice versa); etc…

    Sebi23DU: Sorry, I’m not sure why your forum is blank. There might be an error in your forum configuration. When you set your new forum tables up, did you indicate to phpbb somewhere that the tables are now located in same database as wordpress (i.e, the /root/config.php file in phpbb). Otherwise, I would check your error logs and see what error shows up there…(that is, if you have access to them… e.g. for apache ‘/var/log/httpd/error’…)

    massayoshi: I would check to make sure all files are copied over correctly.

    brian.pan: unfortunately they were copied over correctly. I’m looking at then right now. and I just started a fresh install of both wp and phpbb running on different databases.

    brian.pan: and I still got the message “PHP Single Sign On is almost ready. You have to Follow the instructions for it to work.” when I’m logged in on WP. but I guess this has nothing to do right?

    Don’t know what happened but it’s working right now. Go figure!

Viewing 15 replies - 1 through 15 (of 61 total)
  • The topic ‘[Plugin: PHPBB Single Sign On] Can’t Auth Mode – Option Selected Doesn’t Save’ is closed to new replies.