PhotoPress - Image Taxonomies
[resolved] It does not seem to work for 3.4 (4 posts)

  1. deepak.k.ghosh@gmail.com
    Posted 3 years ago #

    Hey Peter,

    I downloaded this plugin on reading your awesome 'WordPress for Photographers' e-book. I even tried using this plugin on an older version of WordPress, definitely pre-3.4. I was trying to get this set up on my staging site with 3.4, and it does not seem to work at all. I tried uploading a file with all the metadata - EXIF and IPTC. It did not seem to extract and populate the data into the taxonomies.

    Can you please help?



  2. padams
    Plugin Author

    Posted 3 years ago #

    Odd, it works for me under 3.4.1 so it might have to do with the way WordPress is setup on your server.

    One way to tell is to see if WordPress itself extracting any of the basic EXIF meta data (exposure, etc) from the image file. If it is then the plugin could have a bug somewhere. But if it isn't then it might be due to WordPress not having permission to read/access to images files once they are uploaded. Check the permissions on your wp-content/uploads directories.

    You can tell if WordPress is extracting EXIF by looking in your database for the post-meta table or by attempting to display the EXIF through adding some PHP code to your image page template. See this article for how to do that: http://www.bloggingtips.com/2008/07/20/wordpress-gallery-and-exif/

    Let me know what you find out.

  3. padams
    Plugin Author

    Posted 3 years ago #

    Give version 1.2 a try. That version fixes an issue that people were having with the PHP setup of some web hosters.

  4. deepak.k.ghosh@gmail.com
    Posted 3 years ago #

    Works perfectly! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • PhotoPress - Image Taxonomies
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.