Support » Plugins and Hacks » Photonic Gallery for Flickr, Picasa, SmugMug, 500px, Zenfolio and Instagram » [Plugin: Photonic Gallery for Flickr, Picasa, SmugMug and 500px] SmugMug API Key not defined

Viewing 8 replies - 1 through 8 (of 8 total)
  • Whoops! Just found this link: http://aquoid.com/news/plugins/photonic/smugmug/

    Let me try to solve this myself.

    Plugin Author Sayontan Sinha

    (@sayontan)


    Under Settings → Photonic → SmugMug → SmugMug Settings → SmugMug API Key you can enter the API key.

    This looks like the answer to my problems getting a photo grid that links to my SmugMug albums. However, I haven’t been able to get it to display anything yet. I have a page called Photo Albums. I clicked Insert and chose Photonic, then SmugMug, chose All Albums, entered my nickname, clicked Insert into post.

    I have the SmugMug API and Secret in the settings, along with other basic settings for display of thumbnails, etc.

    My page shows only the Header, page title, and comment box, nothing else. What am I missing?

    Plugin Author Sayontan Sinha

    (@sayontan)


    What am I missing?

    Without a URL and the inserted shortcode it is impossible for me to say.

    My blog is local right now – I haven’t uploaded it to the web yet. This is the short code that I see:
    [gallery type='smugmug' view='albums' nick_name='flitorfly' columns='3']

    This is an empty page, except for this bit of code. I was hoping that the page would be filled with thumbnails for the albums.

    I’m new at this, but does Twenty Eleven automatically support short code, or could I be missing some other plugin or code that goes along with this? I see other things in the settings that I’m not familiar with, like jS Library settings. I have Slideshow Libraries set to None in Generic Settings.

    Plugin Author Sayontan Sinha

    (@sayontan)


    The shortcode you have provided works without issues for me. My guess is that you might be hitting some JS errors due to plugin conflicts. Try setting the JS library to one of the provided options, but I believe your problem won’t get resolved due to that.

    You don’t need to do anything special for TwentyEleven – as long as you are entering the shortcode from the “HTML” mode of your editor, it should work fine.

    Sayontan, I finally got it to work – I had omitted a digit on my API Key. Thank you for looking at my problem!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Photonic Gallery for Flickr, Picasa, SmugMug and 500px] SmugMug API Key not defined’ is closed to new replies.