WordPress.org

Support

Support » Plugins and Hacks » [Plugin: PhotoDropper] Photodropper stalled at "Photo saving"

[Plugin: PhotoDropper] Photodropper stalled at "Photo saving"

  • Testing photodropper 2.0.3 and cand get it to work on my localhost.
    Not sure whats causing it, but I can search, and select the image, it loads the HighRes version of it… but when I click on
    “Insert into Post”

    it says “Saving Photo” on top of the image and freezes.

    Any help on getting this to work would be great.

    http://wordpress.org/extend/plugins/photo-dropper/

Viewing 15 replies - 1 through 15 (of 18 total)
  • i would like to have v2 of photodropper running. because the search seems massively improved, bevor v2 it didn’t handle more than one search term.
    BUT: i have the same problem like spabav.

    another issue with v2: i accept the tos, BUT i don’t like that i have to agree with the tos EVERY TIME i want to photodrop an image. my agreement is obviously not stored anywhere.

    possible plugin substitute:
    http://wordpress.org/extend/plugins/free-stock-photos-foter/

    Plugin Author photodropper

    @photodropper

    Hey guys,

    So sorry that you’re having trouble! Sounds like this may be a permissions issue so we’ll work to detect it in the future.

    Can you log into your server via FTP and let me know the owner and permissions on the /wp-content/uploads directory?

    The folder should be owned by the webserver user (often ‘www-data’) and set to 755.

    This allows us to write the image to your server so you have it forever.

    Thanks for your help resolving the issue, let me know if I can clarify anything further!

    -Nicky Hajal

    Plugin Author photodropper

    @photodropper

    More information on file permissions is here: http://codex.wordpress.org/Changing_File_Permissions

    Hello, I have the same problem as spabav above.

    I have checked the file permissions and there’s nothing wrong there. Even a setting of 777 does not mend the problem. Therefore it seems that the photodropper plugin is either broken in WP version 3.3.1 or it is incompatible with another plugin.

    Thesse are the ones I have active:

    Akismet
    Compfight
    Email Obfuscator
    Free Stock Photos Foter
    Google Analytics for WordPress
    Google XML Sitemaps
    lorem shortcode
    Maintenance Mode
    Page Lists Plus
    PhotoDropper
    PHP Execution
    Pretty Link Lite
    Robots Meta
    SI CAPTCHA Anti-Spam
    WordPress SEO
    WP-Optimize
    WP Issuu

    I’m using a theme I developed in Artisteer but that should not be important I think.

    Please find out what’s wrong because I really like the concept of your plugin. IF IT WORKS that is!

    I’m having the same problem too. the folder permissions are 777 on teh uploads directory and still gets stuck on saving photo.

    also, upon each startup, it shows the intro screen asks me to say if my site is commercial and for my email address each time. Seems it isn’t remembering settings properly.

    Plugin Author photodropper

    @photodropper

    Hey guys,

    Thanks, you’re right – I believe the problem was something else.

    If you give the page a hard refresh, the issue should be resolved.

    If you’re still have problems, lemme know and I’ll keep testing.

    Thanks for bearing with us as we get everything smoothed out!

    Nicky Hajal

    OK, settings seem to be remembered now, but saving still does not work.
    Keep digging!

    Plugin Author photodropper

    @photodropper

    Can you open up the javascript console and grab a screenshot of it after trying to save?

    Want to see if there are any errors happening going down.

    -Nicky

    Got the message below from the Firebug Console.
    Is this helpful?

    JSON.parse: unexpected character
    f()load-s…9be1245 (regel 2)
    b = “
    \n<b>Parse error</…on line <b>26</b>

    complete()pd.js (regel 454)
    rsp = Object { readyState=4, responseText=”
    \n<b>Parse error</…n line <b>26</b>
    \n”, status=200, meer…}
    status = “parsererror”
    f()load-s…9be1245 (regel 2)
    b = Object { url=”http://www.falchemist.c…393771674_1332156192914″, isLocal=false, global=true, meer…}
    f = [Object { readyState=4, responseText=”
    \n<b>Parse error</…n line <b>26</b>
    \n”, status=200, meer…}, “parsererror”]
    f()load-s…9be1245 (regel 2)
    b = Object { url=”http://www.falchemist.c…393771674_1332156192914″, isLocal=false, global=true, meer…}
    c = [Object { readyState=4, responseText=”
    \n<b>Parse error</…n line <b>26</b>
    \n”, status=200, meer…}, “parsererror”]
    clone()load-s…9be1245 (regel 4)
    a = 200
    c = “OK”
    l = Object { text=”
    \n<b>Parse error</…n line <b>26</b>
    \n”}
    m = “Date: Mon, 19 Mar 2012 …ontent-Type: text/html\n”
    clone()load-s…9be1245 (regel 4)
    a = readystatechange
    e = undefined
    [Afbreken op deze fout]

    …”resolve”],fail:[b,”reject”],progress:[c,”notify”]},function(a,b){var c=b[0],e=b…

    About the same problem on a multisite Network :
    I met the same problem as written before and now all is working. But I don’t know why!!!

    Owever, my partner follows to find a problem :
    when he can download a picture, the picture doesn’t appear on the article beacause the link is bad : each link looks as …/wp-content/…/picture.jpg?zz=1 instead of …/wp-content/…/picture.jpg
    What means ?zz=1, I don’t know but this is the cause of this problem…

    If this message can help you…

    Same problem here – permissions are fine, and it looks like the plugin has attempted to create the image file on the server but it has a filesize of 0 – so the process is obviously stalled somehow.

    the redesign look fantastic but the plugin is literally unusable for me at this point… kind of a drag! I hope you get it sorted soon…

    (reverted to previous version, which works…)

    Tried the 1.09 version and that works. No wonder if you look at the code inserted into the posts: it refers to the flickr website for the images so there is no need to save the image on your own wordpress server.

    So it seems there’s definitely something fishy with the image saving process in the version 2 series.

    As I really like the feature of accreditation at the very bottom of a post or page I feel like a stakeholder in solving this issue. so if there is a need for testing guys, count me in!

    I may have found what is wrong by chance:

    when I tried to produce a child theme for by WP installation I ran into the situation where absolute url’s were not accepted by the host to access the parent-theme files from within the child theme directory. I did some research and found I had to write a helper function to get the path as defined from the SERVER DOCUMENT ROOT:

    function ParentURL()
    {
    	return str_replace(get_bloginfo('url'), $_SERVER['DOCUMENT_ROOT'], get_bloginfo('template_url'));
    }

    What this does for the template url is to replace the ‘home’ url part in that path by the ‘server document root’ path. so for example:

    http://www.myblog.com/wordpress/wp-content/themes/mytemplate

    will become:

    /home/myhostaccount/domains/myblog.com/public_html/wordpress/wp-content/themes/mytemplate

    It is quite likely that a similar issue exists with accessing the images directory. The host sequrity settings will then block access even if the RW settings seem to permit it.

    I guess it’s worth a try to look at this for photodropper!

    Plugin Author photodropper

    @photodropper

    Hi folks,

    If anyone is still having trouble with this, can you e-mail me so we can discuss some more details about your setup? nicky@photodropper.com

    Thanks so much!
    -Nicky

    Nicky, same problem here.

    Eric

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: PhotoDropper] Photodropper stalled at "Photo saving"’ is closed to new replies.