WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Peter's Collaboration E-mails] Latest update causes fatal error

[Plugin: Peter's Collaboration E-mails] Latest update causes fatal error

  • Updating to the latest version of this plugin yesterday caused this error:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /.../html/wp-content/plugins/peters-collaboration-e-mails/peters_collaboration_emails.php on line 1419

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Peter
    Member

    @pkthree

    Are you on a server running PHP 4?

    I’ve just removed some PHP 5 code — please try again.

    We are running PHP4, but that didn’t seem to do it. We’re still getting the same error.

    Unless I’m not getting the update–I’m seeing “Last updated on 11/27” on the plugin page.

    Plugin Author Peter
    Member

    @pkthree

    I’ve finally set up my PHP 4 testing environment again. There is no PHP error with the fix from a few days ago. I’d suggest downloading the plugin directly from http://downloads.wordpress.org/plugin/peters-collaboration-e-mails.zip and then manually extracting it into your plugins folder, just in case you’ve cached the earlier release that wasn’t compatible with PHP 4.

    jefgodesky
    Member

    @jefgodesky

    That did it! You might want to update the plugin on the WordPress plugin page, too. That version still produces the error. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: Peter's Collaboration E-mails] Latest update causes fatal error’ is closed to new replies.