Support » Plugin: Participants Database » [Plugin: Participants Database] The delete function on main fields page doesn't seem to work

Viewing 15 replies - 1 through 15 (of 31 total)
  • I’m having the same problem; I just installed Participants Database and am trying to edit fields. None of the red “X”s work.

    Plugin Author xnau webdesign

    (@xnau)

    Hi,

    This question pops up a lot. These functions rely on Javascript to work, and it often happens that other plugins interfere with this plugin’s javascript. The best way to troubleshoot this is to disable plugins until you find the culprit. Start with the ones that add admin functionality.

    Turns out, it was my theme that wasn’t allowing it to work! thanks!

    I have a couple of issues:
    1. The response email to my signup has the wrong id #. How do I change this?
    2. What is the difference between [pdp_record] and the wp-content/uploads/participants-database? When I set up my page, does it matter which one I use for the location?
    3. I deactivated all of my plugins and am still not able to delete fields. Can I go around this with pdb_record, selecting only the fields I want?

    Thank you and I greatly appreciate all of the advice you offer. I’ve read so many of your responses and they are extremely helpful.

    Plugin Author xnau webdesign

    (@xnau)

    donnacrupi,

    1. make sure the “Participant Record Page” setting is correct.

    2. use the shortcode [pdb_record] on the page where your users can edit their own record.

    3. Are you using a theme that changes the appearance of the admin? You may need to switch themes to get it working.

    Plugin Author xnau webdesign

    (@xnau)

    For those who are experiencing problems with the delete fields function not working, try uploading this new file:

    http://plugins.svn.wordpress.org/participants-database/tags/1.3.7/js/manage_fields.js

    it goes into the plugin js directory, overwriting the file of the same name:

    wp-content/plugins/participants-database/js/manage_fields.js

    Thanks for getting back to me. I feel like i’m ready to quit and trust me, it’s killing me. I’ve spent two solid days without moving from the computer and the phrase never say die goes a long way with me, but…

    i don’t even see where my csv loaded to. it did upload. i input 3 sets of data and have my page with wp-content/uploads/participants-database/ address.

    I received a response to the signup I filled out and the address sent me to another page on my website – not to where the form was. http://donnacrupi.com/?page_id=139&pid=00LFZ is what was sent and the actual page is http://donnacrupi.com/?page_id=153. I changed the id# in the url and it brought me to the page that said ‘Participants Database’ but there was no questionnaire. Just ‘Leave a Reply’.

    I would love to stick with your site and send a donation. I’ve put a lot into this. If you help (can help) i’m happy not to give up.

    Also, I’ve made no changes to the theme and i deactivated all of the plugins.

    Thanks,

    Donna

    I copied and pasted over the old code. It said it was successful, but nothing changed in pdb. clicking on the red x still brings the page to the top.

    did anyone else have different results?

    Plugin Author xnau webdesign

    (@xnau)

    donnacrupi,

    At this point, you’ll need to debug the Javascript to find out what’s happening. If you use Chrome you can use the developer tools to see what kind of Javascript errors hare happening when you click on the delete red x.

    Did you try changing to the default WP theme to see if the plugin will work then? Might be your theme not allowing the plugin JS to function.

    It sounds like you need to check your setting for the “Participant Record Page” to make sure you’ve got the right page selected.

    The [pdb_record] shortcode won’t show anything unless a valid “pid” value is included in the URL.

    did anyone else have different results?

    The new file did not work for me, either. Still can’t delete. Clicking the red X does absolutely nothing.

    Failed to load resource: the server responded with a status of 404 (Not Found) http://s410995807.onlinehome.us/wp-content/plugins/participants-database/pdb-record.css
    Uncaught TypeError: Object [object Object] has no method ‘propAttr’ load-scripts.php:370
    2
    Uncaught TypeError: Object [object Object] has no method ‘propAttr’ load-scripts.php:370

    Plugin Author xnau webdesign

    (@xnau)

    quartney,

    You probably have another plugin that is conflicting with the Javascript. Try turning other plugins off and see if it helps.

    Hi,
    I have the same problem with red X and Signup Form Settings Record Form Settings also not working.

    I’ve disabled all plugins and this does not fix the problem.

    I’ve also tried two browsers (IE and Firefox) and still don’t seem to be able to get it to work.

    Any ideas?

    change your theme back to the default wordpress theme. delete what you need to, and change the theme back to the one you’re using.

    quartney,

    Thanks for the quick response!

    I have installed themes; twenty ten, twenty eleven, Weaver, Bloglife (various versons). Which one of these is the default?

    Sorry to sound ignortant, but I didn’t setup the page originally so don’t know what was the default.

    going to twenty eleven will work.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Plugin: Participants Database] The delete function on main fields page doesn't seem to work’ is closed to new replies.