Support » Plugin: Participants Database » [Plugin: Participants Database] Form quit working after I put in 400 questions

  • Resolved PeggyMe


    I’m pretty sure that this plug in was not made to accommodate a large amount of questions. (Most people would not need to put in 400 questions) It worked great with about 100 questions, but it does not work with 400.

    I tried changing the php.ini file

    max_execution_time = 600
    max_input_time = 600
    post_max_size = 50M

    That did not work. Any ideas besides writing the code myself? I was trying to save time and even if I have to write this part of the code myself, I have saved a lot of time.

Viewing 8 replies - 1 through 8 (of 8 total)
  • …fyi … it started working again when I reduced the amount of questions to 200.
    …but now I am going to put the questions back in…

    So I am hoping that the Developer/Author of this plug-in will read this and be able to solve this problem… If you read this would you please let me know…even if there is not a simple solution. Thank-You!!

    Try adding this to your php.ini file

    memory_limit = 64M

    You can up this limit for testing (72, 80, 88, 96, 104, 112, 120, 128 etc). My main search display will not work unless I have this set at 768M.
    I have ~108,000 records.


    Thank You Wayne for your idea!!
    I had it set at 80 already. I did try and I keep upping it all the way to 10000M and even this did not work. So I put it back to 80M.

    I really think that it has something to do with the javascript, but I don’t know.
    It will say the it has updated and the changes will be visible, but when I navigate away from the page and then back the changes are not there. ??? Also when I look in the database the changes never got there.

    Plugin Author xnau webdesign



    I just answered a question about things not working with lots of records, now I see that I need to see what happens when a large number of fields are added. I certainly never tested this situation, so I’m glad you’re bringing it to my attention.

    However, I need more specific information. Are you seeing any error messages at all? I assume this happens on the manage database fields page…do you have your fields organized into groups? Do you know the number (besides being between 200 and 400 fields) where things stop working?

    I’m going to look into this.

    So glad to hear from you!
    I do not know the exact # where the form started to work again because i was deleting the questions, page at a time, from the database. It was approximately 200.
    The problem is on the page with the [pdb_record] shortcode.

    I actually did not use the manage database fields page to add all of the questions. My computer took to long just to load that page. I did enter the first 20 or so questions on the manage database fields page.I entered the rest of the questions straight into the database by writing a code that would generate a “upload statement” and then i uploaded the question in bulk that way.
    I did test to see if there was problem with one of the questions or entries in wp_participants_database_fields table. I tested this by deleting the entries page at a time until the form started to work. Then I added all of the questions back into the data base. Then deleted all of the questions that were in the last page that I had deleted at the point when the form had started to work again. And the form did not work. So this I figured was sufficient testing to know that I had not made a mistake in the way I had inputed the questions. (Hope that made sense).

    So back to the page with the [pdb_record] shortcode. I have the questions divided up into 7 categories.

    So here is what happens: When the form gets submitted i get told that “Your survey has been updated”. and the updated information is visible on the page, but not in the database (wp_participants_database). So when i navigate away from that page and come back the information that I updated is not there and never got put into the database.

    Hope that all made sense! Thank you for your help!

    Plugin Author xnau webdesign


    OK, now I get it. What we need to look for are any PHP errors that are generated when the form is submitted. If your site is still in development, you should be able to get those errors by turning WP_DEBUG on (if you haven’t already), then you will need to look in the PHP error log to see what went wrong.

    If the site is live, you can turn on the WP_DEBUG flag conditionally based on your IP.

    You Rock!!!

    It took me awhile to figure out the error log and all of that but this was the problem and now it is fixed.

    WordPress database error: [Identifier name ‘health_insurance_plan_for_employers_administered_internally_comme’ is too long]
    ALTER TABLE wp_participants_database ADD health_insurance_plan_for_employers_administered_internally_comme TEXT NULL

    I thought I would have to change alot of the questions but I guess it was only this one.
    I guess that my method of “testing to see if there was problem with one of the questions” that I explained earlier was flawed.

    Thank You Sooo Much!!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Plugin: Participants Database] Form quit working after I put in 400 questions’ is closed to new replies.