Support » Plugin: Participants Database » [Plugin: Participants Database] Admin field data disappears

  • Non displayed Admin field data (that admins input) disappears after a participant has made further edits. It seems to follow the same rules of approved members, i.e. once a member edits their own data, their page is deactivated until an admin reactivates it, but I don’t want our other admin fields to disappear! Is this a bug or by design?

    Thanks, Em

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author xnau webdesign



    No, it should not do that. I’ll figure out what’s happening and fix it.

    Thank you x

    Hello Roland,

    I have the same issue. Any field group that is not displayed on the pdb_record is rest to the default after a Participant updates their own record. This totally works for me in the admin sections, I set the default of one of my fields to approve so it takes the person off any visible lists I have until I approve them. But I have a field group called lists that is not displayed. All of these fields are also reset to the default when the Participant updates their own record.

    Thanks You,



    I unfortunately have to report the same problem. I thought it was due to my own modifications (I can display field groups depending on the role of the user), but if others reports the problem with the Admin group it means it is not related to my modifications but more of a general problem with the plugin.
    I am looking at this problem, if I find something usefull, I will let you know Roland. It is certainly at line 101 of edit_participant.php.

    See you

    Plugin Author xnau webdesign


    Yes, this is a bug (also know as my mistake!) I’ve got a fix in for this…expect it in a day or so.

    In this update will I lose my ability to kick someone off a published list when they update? If so is there a work around? (Otherwise I’ll have all fields emailed to me when people update.) I don’t expect any major issues, we just have had a few reactive members in the past. ~J

    Plugin Author xnau webdesign


    The latest update solves this issue.

    @tetontrekker not sure I exactly understand what you want to do with that, but I doubt this fix will change it. You can turn off the notification that happens when someone updates their record.

    I’m not using the sign up form, I sign people up. BUT I let them update their own entry. I have an admin radio filed “status” with choices Active(shows on my active member list), Inactive (shows on my inactive member list), and Approve as the default (shows on no list). When someone updates their entry it would go to the approve status and be removed from all public lists. If this not longer works, no big deal, I will just add all the public fields to when gets emailed to me so I can review that way.

    I don’t have time this morning to change things up to go with this update. but the update has a bug. I don’t **think** its user error..

    It is not calling the images from the correct directory. I entered wp-content/participantsdb-uploads/ as the image directory, but the output is

    Gotta get to the slopes before the snow melts… thanks for the new front end sort feature!!! Awesome, can’t wait to set it up.


    Plugin Author xnau webdesign


    Hi Julie,

    The first point, I now understand what you were doing…it appears you were using the “bug” to get the job done. You’re going to have to do this manually, I think, now that the bug has been fixed.

    OK, well I’d like to get to the bottom of your trouble with the images. It all seems to work fin here. Things to check: make certain the setting is correct (of course) because it looks like it’s putting in nothing for the images path. (check the setting for any strange characters that might be throwing thins off) Second, if you can, look at the database entry for a record that has a photo and see what’s there. It should be just the name of the file with no path. Third, make sure the directory where the photos are supposed to be exists and the photos are there. You probably did most of this, but there shouldn’t be any problem if all these check out.

    Hello again, Thanks for the reply. I didn’t know I was exploiting a bug until it was too late. oops.

    About images…

    I checked all of the above. everything looks right. Today while I was out it occurred to me my hack may be the issue so I complete removed it. That made not difference. (Hack: from my original post to you on your website, I had copied the list class and tweaked it to fit one of my pages)

    This is the what I put in the file upload location, the images were working before the update with this setting.


    Today I tried

    none worked. The images show up in admin (the back end) edit screen. with the original setting. I’m stumped.

    I see someone else is haveing this same issue. If you want to move conversation to that thread I marked it to notify me.

    Thanks Again,

    Plugin Author xnau webdesign



    So, you see the image in the admin when you edit the record, but you don’t see the image when you view the list on the website? Do you see it when you view the single record? You should stick to the setting that works…we know that’s not the problem so we can look at other things. Do you have a link you can send me so I can see what you’re seeing?

    Your update fixed it. I added my hack back in one function at a time and it did not break. Thank You.

    Weren’t approved members to be disabled once they’ve made edits (see very beginning of thread above)?

    The new updates now allow editing without disabling the account. I need to be able to check over and format their textareas before the profile is approved again. The textareas have no linebreaks and are a garbled mess without me editing them in rich text!

    Thanks, Em

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: Participants Database] Admin field data disappears’ is closed to new replies.