Support » Plugin: Pagely MultiEdit » [Plugin: MultiEdit] Tab not renderign shortcodes

  • Hello,

    first of all, great plugin, congratulations and thank you so much for delivering it with such good quality.

    To the problem: (really simple)

    Content written in a tab with a [shortcode] doesn’t render the shortcode.

    Is this a known issue? Is there a way to solve it?

    Any filter we can use as in add_filter('widget_text', 'do_shortcode'); with text widget?

    Thank you

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author joshua strebel


    never tested with shortcodes

    This is a big one for me as well… great plugin, btw. Video content is the issue for me. I can embed via shortcode/custom field or iframe embed, but the filter in the tabs is stripping the code on both methods when publishing a page or post.

    Plugins that add iframe embedding are being stripped too, so it seems like the multiedit tabs post area needs the “add_filter”.


    Since Multitab tabs’ information is stored in the custom values, the method should be to apply a filter to the custom values.

    This subject is talked about here
    and here

    What I can understand of what they say, there is no way to apply this filter unless you tamper with the theme itself.

    Is that so? Any way to add a function to the functions.php file that would apply a filter to the information contained in the custom values of the post when being displayed?

    If that function can be made then it could be put in the plugin, right?

    Any follow up or luck here? I’d love to get this resolved.

    I’m assuming it’s something simple because if I add <?php get_sidebar(); ?> just above <?php multieditDisplay(‘Right’); ?> in the same container the sidebar totally works and accepts iframes in a text/html widget… so if I can just get the <?php multieditDisplay(‘Right’); ?> to have the same filtering as <?php get_sidebar(); ?> we are good.


    It dawned on me today that MultiEdit is leveraging custom fields to create the edit tabs, so I search and found this –, which recommends use of this code;

    <?php echo apply_filters(‘the_content’, get_post_meta($post->ID, ‘your_custom_field_here’, true)); ?>

    The problem is, I’m not sure where to place it and if we need to duplicate this code for each field (tab) in the template.


    Change line 63 of /wp-content/plugins/pagely-multiedit/multiedit.php from this:

    echo $GLOBALS['multiEditDisplay'][$index][0];

    to this:

    echo apply_filters('the_content',$GLOBALS['multiEditDisplay'][$index][0]);

    That will apply the standard filters to the output before it’s written to the browser – no need to change your templates.

    If you upgrade the plugin, you’d have to re-edit the file (unless adds this patch to the new version).

    Thank you, Nick! Works perfectly, really appreciate you sharing that fix.

    Thank you all for this post!

    Thanks Nick! You’re solution does work perfectly! Very nice.

    Can anyone help me with this because since all of the updates I am still unable to use shortcodes, and line 63 is not what Nick says is.

    I am trying to add a gallery to a side tab.

    NEVERMIND! Sorry for the brain fart…

    Looks like added a ‘apply filters’ option so you can use short codes now.

    Hi there…was wondering if I could get some help. I have installed Plugin: MultiEdit as well as AnythingSlider.

    The two aren’t playing nice with each other because of the short codes. AnythingSlider requires a short code in order to function [anything_slides].

    If I put in this short code into my page (any one of the MultiEdit tabs) it loads the slider but automatically disables the multiEdit from rendering.

    Note: I have checked Yes to the MultiEdit Short Code Support: and I have used the php echo do_shortcode in the themes custom_home page as well, which also disables the MultiEdit from rendering.

    Here is the site so you can see what I am trying to do:
    I need the slider on top then was wanting to use mutliedit for the three tabs below it.

    Thanks so much for the help!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: MultiEdit] Tab not renderign shortcodes’ is closed to new replies.