Support » Plugin: Page Security & Membership » [Plugin: Page Security by Contexture] User message – Home page link

  • Resolved Gilln

    (@gilln)


    Thanks for the great plugin.
    I am using it to set up a Client area, where clients have Subscriber status and can only view their own page.
    When a client logs in, he is redirected to his particular page (using Peters Login Redirect plugin).
    If he gets curious, and manually changes the page ID# in the browser address bar, he is shown the message:
    “You do not have the appropriate permission to access this page. If you believe you should have access to this page, please contact an administrator for assistance.” Followed by a link … << Go to home page.
    The link doesn’t go anywhere but stays on the same page.
    I am tearing my hair out trying to find where I can change this message and either remove or fix the link.
    I’d really appreciate it if you could point me in the right direction.

    http://wordpress.org/extend/plugins/contexture-page-security/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Matt van Andel

    (@veraxus)

    You can change the message from your admin section under Settings > Page Security. You can either set any custom plain message or select an existing page to use for your Access Denied message.

    Thread Starter Gilln

    (@gilln)

    Thanks so much for the speedy reply. Can’t believe I missed something so simple.
    It wasn’t so much the message that was the problem as the link underneath it going nowhere. But I can solve the problem by setting up a new custom page.
    Thanks again.

    Plugin Author Matt van Andel

    (@veraxus)

    You’re welcome!

    BTW, the message link simply points back to the site root – so if you have a static page set as the homepage, and it’s protected, you would be redirected right back to that Access Denied page/message as if you didn’t go anywhere.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Page Security by Contexture] User message – Home page link’ is closed to new replies.