Support » Plugins » [Plugin: Page Peel] Not working at all – no errors, no page peel

  • I have tried this on both a 2.8.6 WP installation and a 2.8.5.

    I tried it on the 2.8.6 first and got nothing – no error, but no page peel either. Just nothing at all (you can view the site at

    I tried switching to the default theme, and deactivating all other plugins. No dice.

    So then I installed a brand new installation (2.8.5) on a different domain, with no plugins or themes or anything. Just base WP and the Page Peel plugin. Nada. Still doesn’t work. No error, no page peel.

    I asked my host (Hostgator) if there some reason SWF files wouldn’t load and they said they couldn’t see anything.

    Any idea what is keeping this from working? Or does it just not work with 2.8+?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Either you have not activated the plugin, or your theme is not compatible with this plugin (see below). On my website you can see it runs on latest WP (2.8.6 at the moment of writing this post).

    You need to see reference to wp-content/plugins/page-peel/pagepeel-js.php in your website’s HTML source if plugin is activated and theme has support for wp_footer WP action. I don’t see one in your source code.

    Hi, thanks for your reply.

    As I mentioned above, when it didn’t work on the first one, I tried it on a totally fresh install (2.8.6) with nothing but the default theme and no other plugins activated. It still doesn’t work.

    You can see it at

    The plugin IS activated and I checked the pagepeel-js.php file to make sure the correct path was there. Still nada.

    I’m not familiar with the wp_footer WP action support that you mentioned and reading the link you provided didn’t really make it very clear. The default theme does have this right before the </body> tag. Is that all that’s needed or is there something more?

    <?php wp_footer(); ?>

    Anything else that could be keeping it from working?

    Ok, I’m seeing it loads on your test site (reference to a file with JS code above </body> tag) but when I open that file what I see is some messed up paths:

    var ppo = new Object();
    ppo.ad_url = escape('');
    ppo.small_path = 'http://demo.poshblogs.com';
    ppo.small_image = escape('');
    ppo.big_path = 'http://demo.poshblogs.com';
    ppo.big_image = escape('');

    The ppo.small_path and ppo.big_path are wrong and those are generated from your WordPress URL. Please check value of your Settings / General / WordPress address (URL) field. It should be “” but it seems it’s “http://demo.poshblogs.com”


    Okay, that was me trying out putting the entire path in the pagepeel-js.php file to see if it would fix it and forgetting to put it back. I have now fixed that issue.

    That didn’t fix the problem, though. I’m still getting nothing.

    More weirdness to report.

    I checked my desired theme to see if it had the footer code and it didn’t, so I added it right before the </body> code in footer.php. Now Page Peel works on that domain (

    The weird part is that it still won’t work on the other (fresh install) domain, with nothing in it but a couple of themes and no plugins. It will work with the classic and some other themes on the domain, but not on the domain with the same themes. They are both on the same shared server with the same settings.


    Well I can see the plugin has loaded. The Flash object is created but for some reason SWF file is not loaded into that Flash object:

    I really don’t know what is causing SWF not to load, as SWF files are present on your server. You may try to escape SWF paths?

    Open up pagepeel-js.php and make it look like this:

    var ppo = new Object();
    ppo.ad_url = escape('<?php echo get_option(pagepeel_ad_url); ?>');
    ppo.small_path = escape('<?php echo get_settings('siteurl').'/wp-content/plugins/page-peel/pp_sm.swf'; ?>');
    ppo.small_image = escape('<?php echo get_option(pagepeel_image_small); ?>');
    ppo.big_path = escape('<?php echo get_settings('siteurl').'/wp-content/plugins/page-peel/pp_big.swf'; ?>');
    ppo.big_image = escape('<?php echo get_option(pagepeel_image_big); ?>');

    Hi Avram. Just found this topic as i have exactly the same problem on my site Uses Arthemia Premium theme. WP2.8.5

    The plugin is loading. If I do a right click on the top right corner I see the same message as

    I have also edited the pagepeel-js.php with the code above.

    Any other ideas how to get it to work?

    Well if escaping URLs does not help then I really can’t be sure what’s causing problem with loading SWFs

    I use hostgator for my domain and had this problem too. I have not contacted hostgator yet, but I put the files on a different domain / server (not hostgator) and it works for a temporary fix.



    Host Gator peeps, login to chat with hostgator, let them know that the peel php isnt executing the flash file. They will adjust a filewall setting and you will be up and running.

    Hi Guys,

    I had poroblems when I lost the PagePeel “effect and was pulling my hair out. Reading this forum really help, particularly the reference to WP Footer Action.

    Seems when I modified out a footer link, I deleted the footer Script options as well. Now fixed and a lesson learned, Thank You!


    Hi Guys,

    on three of my blogs is this plug-in working just awesome, but on fourth one is not working.

    Any ideas? i don’t have anything like that in footer.



    Hey for those on host gator. I just got off with host gator and here is what you need to say:

    “Have them check mod_security, you have to white list rule 340163”

    It is something they have to do on there end. Hope this helps!

    I was having the same problem with pagepeel-js.php. It was in the correct location but not loading. Turns out that I needed to upgrade my server from PHP4 to PHP5. Everything works correctly since I changed to PHP5.

    (Site hosted on MediaTemple Grid Service.)

    I installed and activated the plugin and nothing happens. I read the above instructions but I am new at this and pretty lost. my site is, any help getting it set up would be great. Thanks.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Page Peel] Not working at all – no errors, no page peel’ is closed to new replies.