Support » Plugin: Page-list » [Plugin: Page-list] Limit content & more tag

  • Resolved Borislav

    (@bobydimitrov)


    It seems the “more tag” content limiting does not work. I don’t have a demo page, as I’m working on a local network site, but it’s easy to reproduce.

    I think if I set the strip_tags=”0″ I can see the “more tag” working, but, of course, that messes up the whole layout, as other tags bleed from the subpages onto the current page.

    http://wordpress.org/extend/plugins/page-list/

Viewing 9 replies - 16 through 24 (of 24 total)
  • Hi webvitaly,

    I just tested this out, but now with version 3.1, my descriptions end with “###more###”. Sometimes, this is truncated, like “###mo”.

    My exact config is: [pagelist_ext parent=20 show_image=0 depth=1 more_tag=1 strip_tags=1]

    Any ideas? Thanks!

    Plugin Author webvitalii

    (@webvitaly)

    2jooooooon42:
    can you send me the link with the problem to my email?

    Borislav

    (@bobydimitrov)

    Tested higher priority “more_tag” – works as expected. Thanks!

    jkirchartz

    (@jkirchartz)

    Just wanted to say that the “more_tag” code uses mb_strpos which isn’t a default-enabled function for PHP. you have to specifically turn it on or install it, and it causes some trouble without it. If it’s not enabled it will give a fatal error and stop rendering the page. This problem is easily fixed as explained in this question on stackoverflow and only happens when using the plugin with the more tag.

    Me too, with simple [pagelist_ext show_image=”0″] it shows “###mor” instead of “Read more” classic button. I’m with 3.5 and last plugin version.

    Plugin Author webvitalii

    (@webvitaly)

    @nigrantonio: imho maybe you have old php on your hosting.

    p.s. There is no “read more” button in Pagelist plugin. “more_tag” param means for shortcode to ignore or not the more-tag in content. You may read about it in Pagelist documentation. Article about why more-tag is bad.

    Yes, I know…anyway:
    I’m on my server with PHP 5.x and more_tag is OK in other pages, but when I use your tag [pagelist_ext] to show subpages, text is less than without more tag, but after stop first <p> it shows me ###mor instead of nothing (or classic “Leggi altro”).

    Plugin Author webvitalii

    (@webvitaly)

    @nigrantonio: I am not from Italy 🙂 I am from Ukraine.
    ‘webvitaly’ means ‘web+vitaly’. ‘Vitaly’ is the name like ‘Vitaly Klitschko‘.

    As I can understand – ‘Pinuccio’ means ‘plugin’ in italian. And ‘Leggi altro’ means ‘read more’. Awesome language, words sound great.

    Write me feedback with more details and I will check it. In english please 😉

    About ‘more-link’: yeah, it is kinda ‘my-way’, but I really believe that it will be good for everyone 🙂

    Sorry, it was simply a citation from our famous song…
    http://it.youtube.com/watch?v=pSL4Z7FYGbU
    …to close off-topic!

    P.S. Now we can continue via feedback page.

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘[Plugin: Page-list] Limit content & more tag’ is closed to new replies.