WordPress.org

Support

Support » Plugins and Hacks » Page Links To » [Plugin: Page Links To] Open in New Window

[Plugin: Page Links To] Open in New Window

Viewing 15 replies - 1 through 15 (of 22 total)
  • bump..

    I’m using the latest WP install..

    i need to know this too…PLEASE HELP 🙁

    Same problem, VERY frustrating. Any help much appreciated.

    Had the same problem, after racking my brain for hours, i figured out why I was getting an error. For some reason, with the new WP install, the link path changed. Mine changed from:
    http://xxxxx.com/archives/category/photography to
    http://xxxxx.com/category/photography

    Hope it helps.

    Also have the same problem, that is despite checking the box that says “Open this link in a new window”, the resulting link opens in the same window, not a new one. That’s confirmed by looking at the HTML, which should have a target=”_blank” as part of the link, but does not.

    Anyone know how to tweak the code to make this happen?

    thanks

    I’ve been trying to do this as well. No success, no support no nothing. This plugin should be removed from wordpress.org.

    ok, I’m a lightweight in the PHP realm, but I did look the code over a few times and decided to try something in the HTML portion that seems to have worked… I noticed that the <input> tags for the 2 checkbox options were inside the <label> tags, which didn’t seem right… so I moved the <input> tags outside and tried it and it’s functioning fine for me, that is I get a redirect in a blank window.

    Look for lines 159 & 160 (for me anyways) in the page-links-to.php file and rework them to be as follows:
    – – – – – – – – – – – –
    <p><input type=”checkbox” name=”txfx_links_to_new_window” id=”txfx_links_to_new_window” value=”_blank” <?php checked( ‘_blank’, get_post_meta( $post->ID, ‘_links_to_target’, true ) ); ?>> <label for=”txfx_links_to_new_window”>Open this link in a new window</label></p>
    <p><input type=”checkbox” name=”txfx_links_to_302″ id=”txfx_links_to_302″ value=”302″ <?php checked( ‘302’, get_post_meta( $post->ID, ‘_links_to_type’, true ) ); ?>> <label for=”txfx_links_to_302″>Use a temporary 302 redirect (default is a permanent 301 redirect)</label></p>
    – – – – – – – – – – – – –

    Hopefully it works for you also.

    It works in the sense that the link opens in a new window, but now the links open in a new window even if the box is not checked.

    I think I may have found the fix! I made the change that chardant suggested above along with the following…

    Line 179 reads:
    delete_post_meta( $post_ID, ‘_links_to_target’ );

    Change it to this:
    update_post_meta( $post_ID, ‘_links_to_target’, ” );

    guys, i’m going to try this and if it works I be your Nr.1 fan forever!

    I really REALLY need this thing to work. Fingers crossed, will post results soon.

    🙁 Can’t get it to work guys. I replace the two lines suggested by chardant, and the suggestion by kustombykris but I can’t get it to work…

    Would you guys be so kind and upload your edited version of the plugin somewhere so I can download and try it?

    I really really need this thing to work.

    Thanks

    I don’t understand, this is still not working for me. I’ve plugged in the new php file and everything. Is there something that could be missing?

    Anyone else having any problems?

    Any further help would be very appreciated thanks so much!

    None of the above is working for me too.

    I notice that the download link points to version 2.4, but the changelog shows a “previous version” 2.4.1. I tried version 2.4.1 but that version does not work either.

    I tried rolling back to (as far back as) version 2.2 to see if that works and it does not.

    I reinstalled version 2.4.1 and created a separate menu. On this menu the page opens in a new tab but not on the standard menu in the theme.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Plugin: Page Links To] Open in New Window’ is closed to new replies.
Skip to toolbar