Page Links To
[resolved] Have problem for several months - author contact or other coding help? (6 posts)

  1. mikeashton
    Posted 3 years ago #

    I've been having a problem with the add-in Page Links To for several months, since upgrading to version 2.6. The fatal error I get when I try to activate is

    Parse error: parse error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /blog1/wp-content/plugins/page-links-to/page-links-to.php on line 29

    I have tried multiple times, in several methods, to contact the author (Mark Jaquith) to see if I can roll back the addin since the prior version worked and is important to our site. I've not gotten a response, so it looks like I have to self-support. But I'm not a coder and I have no idea what that error is or how to fix it. Any help would be appreciated. (I tried to change the static $instance to a var $instance but that just creates another error).

    Thanks in advance,


    (the relevant website, btw, is http://www.inflationinfo.org )


  2. cubecolour
    Posted 3 years ago #

    previous versions of plugins can be download from the plugin page - in the column on the right see the 'other versions' link

    This kind of error is often due to having PHP4 on your hosting when the plugin needs PHP5. - which is required for the current version of WordPress. If your hosting currently only has PHP4, you need to get your hosting environment on PHP5 - contact your hosting company for this. Also you are using an old version of WordPress, so you should also get that up to date.

  3. mikeashton
    Posted 3 years ago #

    Thanks. My hosting company is Yahoo, so I have little chance of getting them to upgrade.

    I was able to roll back to the prior, working version. I suppose that's the version I will have for life, now, since there is no way I'll ever upgrade that add-in since the author is incommunicado.

    Thanks again for the help, cubecolor!

  4. cubecolour
    Posted 3 years ago #

    According to this page you can switch your hosting over to PHP5:


  5. Mark Jaquith
    WordPress Lead Dev
    Plugin Author

    Posted 3 years ago #

    WordPress requires PHP 5.2.4 now. Follow cubecolour's advice and switch over to PHP5, and update to the latest version of WordPress.

  6. mikeashton
    Posted 3 years ago #

    Nice to finally reach you, Mark. It's working fine with the old version. I won't be updating to the new version. I can't really have the site essentially go out of commission for a couple of months again in case it doesn't work right.

    But thanks for finally responding.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Page Links To
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic