WordPress.org

Support

Support » Plugins and Hacks » Ozh' Admin Drop Down Menu » [Resolved] [Plugin: Ozh' Admin Drop Down Menu] Notice: deprecated function found

[Resolved] [Plugin: Ozh' Admin Drop Down Menu] Notice: deprecated function found

  • Hi Ozh,

    Thanks for your great plugin and all of your skillz (i’m reading your book!)

    I know that is not a issue, but like recommended by some best practices, i enable DEBUG on my WP dev version and it fires me some notices from your plugin (version 3.5.3), about deprecated function attribute_escape

    So, i found the lines:

    wp-content\plugins\ozh-admin-drop-down-menu\inc\core.php(line 411):
    $options[$k] = attribute_escape($v);

    wp-content\plugins\ozh-admin-drop-down-menu\inc\options.php(line 281):
    return stripslashes(attribute_escape($string));

    and replace with the good function esc_attr

    I just want to ask you, please, if you can include fixes that avoid notices in next versions of your plugin.

    Thank you very much!

Viewing 1 replies (of 1 total)
  • Plugin Author Ozh

    @ozh

    Hi

    Just found about your message (I don’t read forums here).

    Thanks for the feedback! I’ve just committed a newer version of the plugin with those fixes (there was also an old js_escape() somewhere)

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] [Plugin: Ozh' Admin Drop Down Menu] Notice: deprecated function found’ is closed to new replies.
Skip to toolbar