Support » Plugins » Plugin Organizer Activation Failure Fix

  • Upon activation WordPress says, “Plugin does not have a valid header”. Solution that worked was to check the author’s header against the WP Standard Plugin Information http://codex.wordpress.org/Writing_a_Plugin, whereupon I found the author had not included a license spec.

    Using the arbitrary example given on the codex page above, I edited the last line of the header in plugin-organizer.php to read, “License: GPL2”.

    Viola! successful activation! 🙂

    If the author wishes to use a different license, then perhaps an update of the plugin is in order.

    http://wordpress.org/extend/plugins/plugin-organizer/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Excellent !! Thanks

    It’s been 1 week, and it’s not yet fixed, but thanks to your post

    5 Stars for this plugin, love it !

    Been trying to figure out why this error popped up after version 1. I still haven’t seen it on any of my sites that run this plugin. Dont remember taking the license line out of the header but maybe I did. I’ll release a new version in a couple days that will add the license line into the header.

    I’ve released a new version. Let me know if it activates successfully for you.

    Hi Jeff: I upgraded to your latest revision – activated just fine 🙂 Thanks 🙂

    On another note (but concerning Plugin Organizer) … A couple of things I am curious about:

    I ran “Repair Tables” on my database using PHPMyAdmin and there was a note for each of the 3 PO tables, “The storage engine for the table doesn’t support r…”.

    I could not see past the three periods but I am presuming “r…” denotes, “repair”? I cant immediately tell if anything changed regarding Plugin Organizer after the repair operation, but was wondering if you were aware of this / had any thoughts about it?

    Also, there was a footnote of sorts in the header area of each of the 3 PO tables that says, “InnoDB free: 0 kB” – it is not there for any of my other tables (???) FYI I am using shared hosting, a pretty standard CPanel host. As far as programming / IT expertise, I am one of those armchair WP enthusiasts running my own site for my business who probly knows “just enough to be dangerous” 😉

    FYI http://forums.innodb.com/read.php?4,244,250#msg-250

    p.s. have contacted my host’s support team as well.

    Thanks for any clues / insights.

    I’m specifying the innoDB engine when the table is created. innoDB doesnt support the repair function. I was using innoDB on the server the plugin was created on so it stayed that way. I’ll look at changing that to go with the database default which is usually myisam. You can change the storage engine on the tables to myisam or whatever you use through phpmyadmin if you want.

    http://www.electrictoolbox.com/mysql-change-table-storage-engine/

    Hi Jeff – thanks for the followup – I changed the storage engine to MYISAM to match the rest of my tables very easily and quickly using your instructions.

    Interestingly enough, reading the Wikipedia article about MYISAM http://en.wikipedia.org/wiki/MyISAM, evidently MYISAM is no longer the default storage engine as of MYSQL 5.5. The default is now InnoDB, but my host is not up to MYSQL ver 5.5 yet.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugin Organizer Activation Failure Fix’ is closed to new replies.