WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Organize Series] Breaks Pretty Permalinks

[Resolved] [Plugin: Organize Series] Breaks Pretty Permalinks

Viewing 15 replies - 1 through 15 (of 16 total)
  • Tinklebelle

    @tinklebelle

    Got it working again. Reverted everything back to default on the Organize Series page.

    It’s not what I wanted, but I can live with it.

    Can you tell me what breaks the pretty permalinks when deselected? It may be something I can address if I can reproduce…

    Tinklebelle

    @tinklebelle

    I have not been able to reproduce it myself since finding the issue.

    Originally I had deselected

    Display series navigation links?
    Display series meta information with posts?

    When I went back and reverted to default settings, the error resolved. I’ve tried deselecting them individually and then together and it performed as it should.

    The upgrade to 2.8.5 is when I originally noticed it, and when troubleshooting I deleted the entire folder and installed the 2.8.6 update.

    brandt-net

    @brandt-net

    Yes i have the same problem. I must deactivate the plugin. After i activate the plugin no post found on my site (every time the 404 page).

    I will try to reset the settings. i hope it works then again.
    I am using the neest wordpress version

    Is this resolved? It should be – I haven’t been able to reproduce any of these problems.

    @nerrad thank you for the reminder. I had completely forgotten about this thread.

    The Organize Series plugin also broke my permalinks and gave me a heart attack. Luckily, thereĀ“s a quick fix:

    Go to Settings>Permalinks and then simply save the settings already there (they should be your old settings).

    That’s it!

    I had the same problem yesterday using WP 2.9.2 and 2.1.7 of the plugin. I use Super Cache and Redirect plugins on my site. Whenever I activated the Organize Series plugin, it generated the “No Posts Found” 404 error. All other plugins were deactivated.

    It appears that the Organize Series plugin added an extra trailing slash onto the root domain; e.g. “www.mydomain.com//series/…”. I use the permalink structure “/%post-id%/%postname%/”. At first, I thought it was Super Cache since it generated an error. However, I deactivated that plugin, deleted any Super Cache references in the .htaccess file, and then reactivated that plugin. It worked fine and created new mod rewrite rules in the .htaccess file.

    I then reactivated the Redirection plugin. Again, everything was OK. But as soon as I activated the Organize Series plugin, it generated the “No Posts Found” 404 error.

    Hope that helps – the Organize Series is a great plugin. Hope you can get it fixed. Let me know if I can help further.

    Thanks for the more detailed report gmcmurdie. I’ll reference this in my bug ticket and will try to reproduce and *hopefully find a fix. Aiming for this weekend for the next release of OrgSeries..

    Any luck nerrad? I haven’t been able to use Organize Series for a couple weeks. Is there anything I can do to help?

    sorry but I’m busy on a freelance project that has been taking me longer than I thought it would. The bad news is I’m not doing any work on Organize Series until I’m done it. The good news is that a lot of the things I’m doing on this project will be brought over to the new version of Organize Series that will fix a lot of bugs and add a couple new features.

    Thanks for the update. Looking forward to the new release.

    I’m not a developer by any means… just someone who likes the plugin, and really wanted to keep using it. So, I did a good amount of troubleshooting. The good news… I think I have found a fix.

    This all has to do (I think) with pretty permalinks and the plugin settings after updating any of the plugin settings/parameters in the latest version.

    Here are the steps I took to get things back to normal:

    Step 1. Revert to default settings. You should notice immediately that your site is back up and running, but if you had any changes to the tokens they are all reverted. Those are easily changed again. The tricky part is in step 2.

    Step 2. In the plugin settings, tweak the “Series Custom Base” to the correct path of your series posts… so something like ” /subdirectory/series “… If you are like me, I had always left that Series Custom Base field blank. I then upgraded to the latest version of the plugin (a few weeks ago). So, just today when I made a change to one of the meta fields in the plugin settings and clicked “Update Options” I immediately noticed the Series Custom Base then had a trailing slash “/” in the field – this is when all heck broke loose, and my site no longer delivered my content properly.

    Step 3. Send me a message and I might be able to walk you through it a little more.

    Good luck,
    Ethan (aka Bentforkz)

    Just checking back. Any update Darren on when you may get to this? Thanks.

    Bentforkz – Haven’t heard anything. How can I send you a message?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] [Plugin: Organize Series] Breaks Pretty Permalinks’ is closed to new replies.
Skip to toolbar