Server error: open_basedir restriction in effect when using optiontree plugin (3 posts)

  1. printing414
    Posted 3 years ago #

    Any help would be appreciated. We bought a new wordpress theme: Pissmo and uploaded it into our server. There's a problem between the server and the wordpress theme. The optiontree plugin is not found and does not connect. We are getting this error message;

    Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(C:\Inetpub\vhosts\ozahmad.com\httpdocs/wp-content/plugins/C:\Inetpub\vhosts\ozahmad.com\httpdocs\wp-content\plugins\option-tree/languages/option-tree-en_US.mo) is not within the allowed path(s): (C:\Inetpub\vhosts\ozahmad.com\httpdocs\;C:\Windows\Temp) in C:\Inetpub\vhosts\ozahmad.com\httpdocs\wp-includes\l10n.php on line 339

    We have changed the settings in the server to all it to be unrestricted with no luck.

    Any insights?



  2. Derek Herman
    Plugin Author

    Posted 3 years ago #

    Why are you telling WP that you are using english? English is the default language and you don't need to add it to your config.php file. Basically the error is saying the english file is missing, but there isn't one because the plugin is in english.

  3. tcarden
    Posted 3 years ago #

    I'm getting the same error and tried your suggestion Derek. I was wondering if you could clarify a little...

    Apologies for my ignorance but am using this plugin for the first time. In my wp-config.php file there is no language set (just set to the default).

    The line in question in wp-config.php is:
    define('WPLANG', '');

    However the plugin seems to be giving the error same error as printing414 noted above:
    option-tree-en_US.mo is not within the allowed path(s)

    See it live here:

    Any ideas would be much appreciated.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • OptionTree
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic