Support » Plugin: TablePress » Plugin Options ONLY work in Chrome

Viewing 10 replies - 1 through 10 (of 10 total)
  • Bob

    (@bobschecter)

    Too many Options spoils the broth it seems. Manipulating too many columns works fine only in Chrome. I settled for less.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi Bob,

    thanks for your question, and sorry for the trouble.

    I’m not really sure what you mean. The “Plugin Options” only has the “Custom CSS” field and the language and admin menu position settings. All of those work fine for me in all browsers, and there’s no code to only make it work in Chrome for example.
    Could this be some local caching issue, or maybe something caused by a browser extension?

    Regards,
    Tobias

    Bob

    (@bobschecter)

    I think I was trying to do too much at once and somehow created a conflict, though oddly that conflict didn’t show up in Chrome, but did in IE and Mozilla.

    Or it might have been the added column that I used to shift things to the left.

    Nevertheless, I deleted that column so at least things show up properly albeit ugly.

    Not worth working through, so I gave up :).

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi Bob,

    ok, that still sounds strange, but good to hear that you got things working again 🙂

    Best wishes,
    Tobias

    Bob

    (@bobschecter)

    Just for the hell of it, I recreated the error.

    Check out http://dmiworks.com/lantana/sample/

    view it in Chrome, as it is supposed to look and then in Mozilla or IE.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi Bob,

    ah, ok, now I see. The reason for this is some CSS code in your theme, which (I have no clue why) adds a maximum width to table cells. Only Firefox and IE seem to obey that CSS, which is why things look odd there.
    The best fix for this would be to override this CSS again, for all TablePress tables. For that, please add this to the “Custom CSS” textarea on the “Plugin Options” screen of TablePress:

    #content-area .tablepress td,
    #content-area .tablepress th {
      max-width: none;
    }

    Regards,
    Tobias

    Bob

    (@bobschecter)

    Thanks Tobias

    That worked. Now I have to figure out where the “max” css is being presented by the theme.

    Have a great holiday.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi Bob,

    great! Thanks for the confirmation and yet another donation, I really appreciate it!

    The CSS is in the /wp-content/themes/Divi/style.css file, in the section around line 2135. I assume that they use this for some kind of responsiveness or something.

    Best wishes and also Happy Holidays!
    Tobias

    Bob

    (@bobschecter)

    Thanks Tobias.

    My pleasure – and clearly I get more than we give.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi Bob,

    thanks again! You are very welcome!

    Best wishes,
    Tobias

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Plugin Options ONLY work in Chrome’ is closed to new replies.