WordPress.org

Support

Support » Plugins and Hacks » [Plugin] Option-Tree don't work with wordpress multisite

[Plugin] Option-Tree don't work with wordpress multisite

  • It looks like that the current release of the option-tree plugin
    doesn’t work at a wordpress multisite install.
    The image links at the backend are broken and also i got the wrong image-pathes for uploads and sliders.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m currently developing the plugin in a Multisite environment but if you can be more specific about your current setup that would help me find a patch.

    Hi Derek,

    I’m not the OP, but I have a multisite install – with subdirectories, not subdomains – where I want to test all of the premium themes within a company. Each ‘site’ on the multisite will be a test site for each of the themes and each of the themes has a different OptionTree set of options.

    What’s happened for me is that the theme that was active when I had to do a network activate of OptionTree, that’s the theme options I get no matter which theme I’m using, which doesn’t actually apply to any of the other themes…

    If there’s anything I can do to make it not need to be network activated, or keep each ‘site’ unique, that would make things a lot easier…

    Thanks!

    i try to activate in multi site with subdomains and give me this message :

    Fatal error: Cannot redeclare get_option_tree() (previously declared in /home/cobra/public_html/wp-content/themes/especial/libraries/theme-options.php:23) in /home/cobra/public_html/wp-content/plugins/option-tree/functions/get-option-tree.php on line 52

    @b_dark try v 1.1.8.1

    @laurie can you email me or something with login details to your network so I can see what is happening?

    @derek Herman perfect is working now!!thnx for the asap solution!

    Hi,

    Separate issue but related to multisite…..

    We have developed a theme using OptionTree and are using it on a multisite. We have installed a blog templates plugin so when people register a site they can select a template that already has the settings already set up.

    The problem is everything but the field options in OptionTree are being carried over. What can we do to force the values in each of the fields to remain intact on new sites created using a template?

    Thanks

    Laurie

    @elle_media

    @derek I emailed you login info to my test site last week. Did you receive it? Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin] Option-Tree don't work with wordpress multisite’ is closed to new replies.
Skip to toolbar