WordPress.org

Forums

WordPress Popup - Optin Revolution
[resolved] [Plugin: Optin Revolution] No Editing Toolbar, etc (35 posts)

  1. clarkk
    Member
    Posted 2 years ago #

    Several issues - no editing toolbar, the button and image uploaders are not working, and the Preview button doesn't work.

    The HTML code appears on the stage rather than the popup preview image.

    When I click on Save - I get the message "Success" in the browser with a link to an ajax file: /wp-admin/admin-ajax.php

    Upon enabling and going to the website - a blank white pop-up appears. The X (close) button does not work.

    This would be a great plugin if it worked. I'd really like to get it to work - was using Pop-Up Domination but it did not play nice when I upgraded to 3.3.1.

    Suggestions?
    clarkk

    http://wordpress.org/extend/plugins/optin-revolution/

  2. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    Could you please let me know the interent browser you are using and version. Could you also provide a url your wordpress blog.

  3. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    Also provide a list of installed plugin and what theme you are using.

  4. clarkk
    Member
    Posted 2 years ago #

    http://michigan-made.com (Optin Revolution is deactivated)
    Wordpress Multi 3.3.1
    Firefox 15.0.1
    Storefront Instant Theme
    Akismet
    All in One SEO Pack
    Breadcrumb Nav XT
    Configurable Tag Cloud
    Contact Form 7
    Facebook Like
    Google Analytics for WordPress
    Google XML Sitemaps
    Kimili Flash Embed
    Multisite Global Search
    My Category Order
    My Link Order
    OPML Importer
    PC Robots.txt
    Pinterest "Pin It" Button
    Promotion Slider
    Really Simple Captcha
    Recent Posts Slider
    Simple Facebook Share Button
    Special Recent Posts
    Sucuri Security
    Tweet This
    WordPress.com Stats
    wp-jquery-lightbox
    WP-PageNavi
    WPMU Recent Posts Widget
    WP Super Cache

  5. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    Could you enable the plugin for 5 minutes post back when it's enabled, I'd like to see the popup.

  6. clarkk
    Member
    Posted 2 years ago #

    Thank you for assisting me with this optinrevolution. I installed the plugin on another site - http://greatlakesinspectioncompany.com

    It has the same issues as mentioned above. Here are this sites wordpress details:

    Theme: Graphine
    All in One SEO Pack
    Configurable Tag Cloud
    Contact Form 7
    My Link Order
    My Page Order
    Really Simple CAPTCHA
    Yoast Breadcrumbs
    (NOTE: I disabled all of these plugins and still did not help).

    One other thing I forgot to mention - I can not change the data in the fields with a slider (Input Fields Setup, Window Setup, etc) - have to use the slider - don't know if that's a bug.

    Also forgot to mention, instead of the edit toolbar on the Optin Popup 1 Settings page - there is the regular toolbar (b, i, link, b-quote, etc).

    Also forgot to mention, when I click the "Reset" button on the Optin Popup 1 Settings page - that is when the html code appears on the stage. The code begins with:
    <div id="simplemodal-container" style="width: 600px; height: 420px; border: 8px solid #000000; background-color: #ffffff; -moz-border-radius: 25px; -webkit-border-radius: 25px; border-radius: 25px;"><div id="close" class="close2" style="left:574px; top:-26px;"> </div><div id="simplemodal-data" class="simplemodal-data"><div style="position: absolute; left: 29px; top: 8px; z-index: 1; text-align: center; width: 90%;"><span><span style="font-family: impact, chicago; font-size: 30pt; color: #ff0000;">DISCOVER HOW I INCREASED MY OPTIN RATE BY 500% IN 5 MINS!</span>
    </span></div>.......yada yada.

    I will leave Optin Revolution plugin enabled for a bit so that you can check it out. I will have to disable it asap though as the pop-up box will not close.

    Hope this info helps.
    clarkk

  7. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you, we will have a look at the site today. What version of wordpress is the site running? Please leave optin revolution on.
    -----

    One other thing I forgot to mention - I can not change the data in the fields with a slider (Input Fields Setup, Window Setup, etc) - have to use the slider - don't know if that's a bug.

    Not a bug the sliders are the way you need to change these settings.

  8. clarkk
    Member
    Posted 2 years ago #

    Same as the other site - WordPress 3.3.1.

  9. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    We have tested the plugin unsing WordPress 3.3.1 with the theme Graphine and could not replicate your problem. If you send login details to http://greatlakesinspectioncompany.com both blog and cpanel we would be happy to take a look. If you'd like us to help resolve this issue for send the details to support [at] optinrevolution.com

  10. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    Let me know if this is possible even access to wordpress admin will help. There is a javascript error but will need access to fix.

  11. clarkk
    Member
    Posted 2 years ago #

    FTP access sent via email.

  12. Ruth Maude
    Member
    Posted 2 years ago #

    I'm having the same problem on http://learnwp.ca I'm running WordPress 3.4.2

  13. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you we will be release an update shortly to address this problem.

  14. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    Please upgrade to version 1.0.2. We have just release version 1.0.2 which now uses the WordPress Media WordPress to add images and button to the WordPress Popup stage. There is a video tutorial which goes over adding images and button to the stage using the WordPress Media Library. http://www.youtube.com/watch?v=3LMZqiRV-JE

  15. jstalker
    Member
    Posted 2 years ago #

    I'm having exactly the same problem with WordPress 3.4.1. I'm using Optinrevolution 1.0.3. I've had to deactivate your plugin as it's just showing a blank popup.

  16. vorm360
    Member
    Posted 2 years ago #

    Still the same problems with WP 3.4.2 and OR 1.0.3 on a Mac in Safari, Firefox.
    Also no Mailchimp connection

  17. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    @jstalker please send a temp login to your wordpress blog to support [at] optinrevolution.com and we will have a look.

  18. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    @vorm360 please send a temp login to your wordpress blog to support [at] optinrevolution.com and we will have a look.

  19. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    @vorm360 please login and test the popup. The image directory was changed. I disabled the enabled the plugin and it reset the popup stage. The image path looks correct now.

  20. vorm360
    Member
    Posted 2 years ago #

    Hi, tested the pop-up, Pop-up on home page once=ok.
    In dashboard: deactivated and activated plugin. now html text has gone, but no preview (white, blanc) and no image upload possible. after saving some settings I see the 'success' page

  21. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    I have had a look, there is an issue with the text editor. We are looking into this. To upload an image there is a tutorial video here.

    http://www.youtube.com/watch?v=3LMZqiRV-JE&autoplay=1&rel=0

    You need to use the WordPress Media Library.

    I can't replicate the "now html text has gone, but no preview (white, blanc)"

    Please send a screen shot of this.

  22. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    @vorm360 We would like to reinstall the plugin but are being prompted for ftp details please provide these details to allow us to reinstall the optin rev plugin and continue our investigation. Send the ftp details to support [at] optinrevolution.com

  23. clarkk
    Member
    Posted 2 years ago #

    Hi optinrevolution,
    I see my post is marked as "resolved" - but sorry to say it is not. I see you fixed the image upload issue. However the stage is the problem on page=optin1

    I upgraded to the 1.0.3 version and it does not make a difference with the issues that I have (on 2 sites that use 2 different themes).

    We did the testing on http://greatlakesinspectioncompany.com site.

    Using Firefox 15.0.1 and WordPress 3.3.1 and Graphene theme.

    The issues I had, and still have are:
    1. The edit toolbar does not appear at the top of the stage (it's just the standard b, i, link b-quote, etc buttons).
    2. The HTML code appears on the stage rather than the popup preview image.
    3. When I click on the Preview button, nothing happens.
    4. When I click on the Save button - I get the message "Success" in the browser with a link to an ajax file: /wp-admin/admin-ajax.php. If use the Back button of my browser - the changes do not "stick". If I manually put http://website.com/wp-admin/admin.php?page=optin1 in the address field, the changes to stick.

    Again....I'd love to use this. But it's not working yet. The FTP and WP login I gave you is still good if you want to check things out.

    BTW....I love the animation at the beginning of the video :)

  24. brorobw
    Member
    Posted 2 years ago #

    I've had the same problem. Here's a quickfix answer and solution. It seems Optin Revolution's editor uses the same setting as the LAST post or page edit. If you were using the HTML editor, then that's the text editor you have in Optin Revolution. Go back to "Posts", select any post. When you go into edit switch from the HTML editor to the WYSIWYG editor. Click "Update". Now go back and Optin Revolution Editor should be back to the WYSIWYG editor.

    I have a couple of problems with 1.02. Will start another thread for those.

  25. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    @clarkk thank you for your feedback we are looking into these problems.

    @brorobw we have made some changes to the WYSIWYG editor in version 1.0.4. not yet release but will be within 24 hours.

  26. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    @clarkk I have upgraded you to version 1.0.4 and tested please check.

    @vorm360 I have upgraded you to version 1.0.4 and tested please check.

    @jstalker I have upgraded you to version 1.0.4 and tested please check.

    @brorobw version 1.0.4 has been released please update your version and test.

  27. clarkk
    Member
    Posted 2 years ago #

    @brorobw - thanks for the quick fix! That did indeed force the WYSIWYG editor to appear.

    Here are issues with the WYSIWYG editor:
    1. I am not able to edit the text on the stage. I had to delete it (not sure this is a bug - thought I'd be able to just highlight the default text and change it to what I wanted within the already made text box).
    2. Used the Insert Text Box - but still can not edit the text (the "Some text here" text won't change).
    3. Used the "Text Popup Editing" tool. I add the text I want to use, click on Update. But the text I create disappears.
    4. I am able to insert my images from the media library - but the drag tool is not working so doesn't allow me to reposition the inserted image.
    5. I used the Reset button and the default text/images reappeared. But then all of the editing buttons were disabled (greyed out) except the Drag button. Clicked that a few times and the Align buttons appeared...and worked. Then the Insert Textbox was enabled so clicked that (but still didn't work). Then the Text Popup button was enabled (but not working). Then the Drag button did start working and I was able to drag items on the stage.

    Seems the WYSIWYG buttons are kind of flaky. That's it for now.

  28. clarkk
    Member
    Posted 2 years ago #

    @optinrevolution - I was working in the dashboard of greatlakesinspectioncompany.com when you posted the update. So I went into the backend of another site and tested optinrevolution - the upgrade did in fact fix the WYSIWYG editor - it now appears automatically and the Preview button works.

    But the 5 issues I noted above are still exist. The WYSIWYG buttons seem to be very flaky.

    Hopefully you'll get there....would love to use this plugin.

  29. Optin Revolution
    Member
    Plugin Author

    Posted 2 years ago #

    @clarkk I just logged into your site and test. There is a problem with the text editor when deleting the last character we will fix this tomorrow.

    I had no problem moving,editing or adding a new text field on your site, but will test again to make sure there are no issues.

    Also added a new button and image no issue moving. There are 2 setting on the editor by clicking the last + button this either enables moving or editing. When moving is enabled all other button will be greyed out.

    On the below there are 2 setting as above move and edit. You will need to click the last button on the right this either enables moving or editing.

    I used the Reset button and the default text/images reappeared. But then all of the editing buttons were disabled (greyed out) except the Drag button. Clicked that a few times and the Align buttons appeared...and worked. Then the Insert Textbox was enabled so clicked that (but still didn't work). Then the Text Popup button was enabled (but not working). Then the Drag button did start working and I was able to drag items on the stage.

    We will change this tomorrow so it will be alot clear when either editing or moving objects on the stage.

    Thank you for your feedback.

  30. vorm360
    Member
    Posted 2 years ago #

    Hi Dean,
    Thnx very much for the update. Preview works ok. Though still having the same problems like clarkk. Moving works but is it possible to scale? Also could not figure out how to position layers back to front (and font to back)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic