Support » Plugin: Optimize Database after Deleting Revisions » [Plugin: Optimize Database after Deleting Revisions] has_cap warning (when debug enabled)

  • Resolved petskratt

    (@petskratt)


    When debug messages are allowed WP displays Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead.

    That’s from using user level 8 on line 18 – should be ‘administrator’ I guess…

    btw, one more warning – Notice: Undefined variable: operation in .../wp-content/plugins/rvg-optimize-database/rvg-optimize-db.php on line 97 (presumably a totally abandoned line of code?)

    http://wordpress.org/extend/plugins/rvg-optimize-database/

Viewing 1 replies (of 1 total)
  • Plugin Author cageehv

    (@cageehv)

    Hi Petskratt!

    Thanks for your feedback.

    Just released version 1.0.5 which solves the problems you mentioned.

    Enjoy!

    Rolf van Gelder

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Optimize Database after Deleting Revisions] has_cap warning (when debug enabled)’ is closed to new replies.