WordPress.org

Ready to get started?Download WordPress

Forums

OpenSearchServer Search
[resolved] [Plugin: OpenSearchServer] Bug? (6 posts)

  1. janbletz
    Member
    Posted 3 years ago #

    I get an error when I install opensearchserver:

    Fatal error: OSS_API won't work whitout curl extension in C:\xampp\htdocs\wordpress\wp-content\plugins\opensearchserver-search\OSS_API.class.php on line 23

    http://wordpress.org/extend/plugins/opensearchserver-search/

  2. ekeller
    Member
    Plugin Author

    Posted 3 years ago #

    The OpenSearchServer PHP client needs the php-curl extension.
    You just have to install it (and probably restart your web server).
    php-curl

  3. janbletz
    Member
    Posted 3 years ago #

    Thank you! Bit too complicated for me, but I'll keep it in mind.

    Jan

  4. naveenann
    Member
    Plugin Author

    Posted 3 years ago #

    To enable curl library with XAMPP we need to modify the php.ini files in our xampp folder.

    1) Locate the following files:
    C:\Program Files\xampp\apache\bin\php.ini
    C:\Program Files\xampp\php\php.ini
    C:\Program Files\xampp\php\php4\php.ini

    2) Uncomment the following line on your php.ini file by removing the semicolon.

    ;extension=php_curl.dll

    3) Restart your apache server.

    4) Check your phpinfo if curl was properly enabled.

    Reference:http://www.tildemark.com/programming/php/enable-curl-with-xampp-on-windows-xp.html

  5. janbletz
    Member
    Posted 3 years ago #

    Thank you!

  6. janbletz
    Member
    Posted 3 years ago #

    P.S. the php4-directory isn't there anymore, but Curl still works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic