Support » Plugins » [Plugin: OpenID] Failure every time with three PHP warnings

  • I am setting up a new blog with WordPress 2.7.1 and the OpenID 3.2.1 plugin. I provide my own OpenID already with phpMyID, so I haven’t enabled that functionality in the WordPress plugin at all — I just installed the plugin so others with OpenIDs will be able to login and comment.

    I’ve tried inputting my OpenID in two different places — one on the login page, and the other in the Dashboard’s “Your IDs” page trying to associate an OpenID with my WP account — and in both places the plugin has died completely with three PHP warnings:

    Warning: Call-time pass-by-reference has been deprecated – argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/blogsite/blog/wp-content/plugins/openid/Auth/OpenID/AX.php on line 891

    Warning: Call-time pass-by-reference has been deprecated – argument passed by value; If you would like to pass it by reference, modify the declaration of [runtime function name](). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/blogsite/blog/wp-content/plugins/openid/Auth/OpenID/AX.php on line 963

    Warning: Cannot modify header information – headers already sent by (output started at /home/insanityfarm/comingsoon/wp-content/plugins/openid/Auth/OpenID/AX.php:891) in /home/blogsite/blog/wp-includes/pluggable.php on line 850

    I’ve searched and searched, and I can’t find anyone else discussing this issue, so I’m not sure why I’m having trouble with it. I’m using the plugin straight “out of the box” with no hacks or customization. Is it possible phpMyID is causing an issue, even though it’s located at http://www.domain.com/identity/ and WordPress is at http://www.domain.com/blog/wp-admin/ ? Or anything else I’m not thinking of?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I should probably add that when I first encountered this issue, I did not have the XRDS-Simple plugin installed. I have since added it in hopes of fixing the issue, but it didn’t help. I’m not entirely clear on what XRDS is for, but the OpenID plugin suggested that it was needed for some functionality.

    Also, I’m running PHP 5.0.4. From what I’ve found so far, the first two warnings are related to that, but should not terminate the script. So apparently it’s the third one that’s causing the problem?

    I am having exactly the same problem on http://www.joanko.net, using WordPress 2.7 and OpenID plugin 3.2.1. I cannot find anyone discussing it on the net.

    Any solutions would be much appreciated.

    Hi everyone,

    The solution described here by jschuur worked for me!
    See Issue 114: Depreciated pass-by-reference causes warnings when using PHP5

    “Removing the ampersands from both Auth_OpenID::update() calls in question seemed to
    remove the warning and not cause any further harm.”

    Great tip, thanks for posting that! I’m now able to use the plugin but I still can’t login with my OpenID. I’m suspecting this is a problem with phpMyID, not the OpenID plugin. I may just disable it and use the plugin as a provider instead.

    as mentioned on the bug report joanium linked to, this is now fixed in trunk and will be in the 3.2.2 release.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: OpenID] Failure every time with three PHP warnings’ is closed to new replies.