WordPress.org

Support

Support » Plugins and Hacks » OpenMenu - The official plugin for OpenMenu » [Resolved] [Plugin: Open Menu – The official plugin for Open Menu] Can't get this working

[Resolved] [Plugin: Open Menu – The official plugin for Open Menu] Can't get this working

  • I just spent a lot of time entering an entire menu in on the open menu site hoping to use it with the wordpress plugin, but i cant seem to get it working. I also got a ton of errors, like mentioned in another post. It was suggested to change the plugin folder to openmenu from open-menu. I did that, and the errors disappeared, but still no menu, it just loads the home page, and if i click on the Open Menu Menu option in the admin panel, now it just says invalid post type. Any suggestions?

    http://wordpress.org/extend/plugins/open-menu/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Just to add, here are the errors im getting:

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 1: parser error : Space required after the Public Identifier in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: <!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”> in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 1: parser error : SystemLiteral ” or ‘ expected in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: <!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”> in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 1: parser error : SYSTEM or PUBLIC, the URI is missing in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: <!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”> in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 16: parser error : Opening and ending tag mismatch: hr line 14 and body in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: </body></html> in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 16: parser error : Opening and ending tag mismatch: body line 4 and html in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: </body></html> in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 17: parser error : Premature end of data in tag html line 2 in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /home/houseofp/public_html/wp-content/plugins/open-menu/toolbox/class-omf-reader.php on line 529

    Plugin Author OpenMenu

    @openmenu

    Sounds like its not pointing to the Open Menu Format menu (in XML) as it expects. What is the URL of your Open Menu Format menu. I’ll check it out and get any issues resolved.

    Thanks for getting back to me. The URL is http://www.houseofpizzapa.com/menus/house-of-pizza-menu.xml. If i paste that in a browser, i can see all the unformated text, so im pretty sure that should be accurate.

    Plugin Author OpenMenu

    @openmenu

    Trying going directly to your menu. Authorization is required. That’s why the plugin will not work.

    (click the link to your menu)

    Ah, thanks so much. I wasnt even thinking about that. Ive got it working now, but i have one further question. Symbols like “, &, etc. are not showing up but rather im getting &quot and &amp — is there anyway of changing this, or should i just change those to the actual words, like “and” and “inch”

    I also notice that the “menu options” get cut off after a certain number of characters, or one line. im guessing i could resolve that by putting in multiple options instead of squeezing it all into one for each group, but i thought it worth mentioning.

    Plugin Author OpenMenu

    @openmenu

    I will look into this later today / tonight.

    (I can only help if I have access to your menu location and I’m still getting permission issues)

    ill open the permissions shortly then. thanks.

    Plugin Author OpenMenu

    @openmenu

    You should keep the permissions open. The whole point of Open Menu is you control your menu and others consume the accurate information into their restaurant based websites and applications. This lets you stay in control of the information others are displaying about your restaurant.

    If you want to discuss this further or have any other comments or suggestions please contact me through the contact page on Open Menu. Always looking to make things better.

    Yeah, the only reason i have the site password protected for now, is because the website is not complete yet. I just removed the password protection though, so you can take a look. Thanks!

    Plugin Author OpenMenu

    @openmenu

    I will take a look in a bit.

    Please consider voting for the plugin and marking that it works.

    Thanx,.

    Plugin Author OpenMenu

    @openmenu

    I see the problem. Now I just have to figure out where the issue was introduced. I will be looking at this tomorrow.

    (I think the issue is going to be resolved by updating the plugin so you won’t have to update your menu)

    Perfect, thank you. I look forward to hearing back from you.

    Plugin Author OpenMenu

    @openmenu

    Found the issue. v1.1.3 update will becoming tomorrow.

    Plugin Author OpenMenu

    @openmenu

    jeezyo – Please consider voting for the plugin too.

    Also, if you have suggestions for improvements let me know.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] [Plugin: Open Menu – The official plugin for Open Menu] Can't get this working’ is closed to new replies.
Skip to toolbar