Support » Plugin: Contact-Form-7: 3rd-Party Integration » Plugin only submitting 'is value' fields to Salesforce

  • Resolved fastasleep

    (@fastasleep)


    Leads started showing up blank at some point in the semi-recent past (not sure when), and in troubleshooting it, I quickly realized that it’s submitting only the fields with ‘is value’ checked, which is bizarre. So just to verify, I checked another field that shouldn’t be ‘is value’, and it showed up in the array:

    BEFORE:
    *** Post (to Service) ***
    Array
    (
    [oid] => 00D70000000KGjl
    [recordType] => 012700000009X5k
    [submit] => submit
    [lead_source] => Website Forms Contact Us
    [Campaign_ID] => 70170000000i8FI
    )

    AFTER checking is value for ‘first-name’:
    *** Post (to Service) ***
    Array
    (
    [oid] => 00D70000000KGjl
    [recordType] => 012700000009X5k
    [first_name] => first-name
    [submit] => submit
    [lead_source] => Website Forms Contact Us
    [Campaign_ID] => 70170000000i8FI
    )

    Getting response as OK and the leads are submitting, but with all the non-checked fields as not provided.

    Did a CF7 update break this or something? Anyone know? I know this plugin is no longer supported, and I plan to migrate to the newer one, but would prefer to just fix this quickly for now.

    Thanks!

    https://wordpress.org/plugins/contact-form-7-3rd-party-integration/

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Plugin only submitting 'is value' fields to Salesforce’ is closed to new replies.