WordPress.org

Forums

Online Backup for WordPress
[resolved] Not working with 3.2.1 (15 posts)

  1. charlesemerson
    Member
    Posted 3 years ago #

    Using Bitnami AMI on EC2 - Thanks

    Probably a simple fix - odds are just not seeing something in the config or database table schema.

    Here's the log:

    30th Jul 2011 6.00.48 PM Error The backup failed: A database operation failed. Please consult the event log for more information.
    30th Jul 2011 6.00.48 PM Error A database operation failed.
    Please try reinstalling the plugin - in most cases this will repair the database.
    Please contact support if the issue persists, providing the complete event log for the activity. Error information follows:
    Location: 337:/opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/wponlinebackup/include/files.php
    Message: WPDB error: Table 'bitnami_wordpress.wp_wponlinebackup_items' doesn't exist. Last query: INSERT INTO wp_wponlinebackup_items (bin, item_id, parent_id, type, name, path, backup, activity_id, counter) VALUES (2, 1, 0, 0, 'htdocs', '/', 1, 1, 0) ON DUPLICATE KEY UPDATE type = 0, name = 'htdocs', path = '/', backup = IF(exists IS NULL, 1, 0), activity_id = 1, counter = 0

    http://wordpress.org/extend/plugins/wponlinebackup/

  2. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi charlesemerson,

    Have you tried reinstalling the plugin?
    Deactivate then delete and then install again.

    Also is this a hosted WordPress platform or did you install WordPress yourself? The other possible reason for this is the database user WordPress is using is unable to create new tables, but you'd need to contact the host if this is the case.

    Regards,

    Jason.

  3. charlesemerson
    Member
    Posted 3 years ago #

    G'Day Mate,

    Thanks for the quick reply on a Sunday afternoon (US) :-D

    This is an Amazon EC2 server - deployed using the Amazon Bitnami WordPress AMI (quite superb overall) & the TouchSense theme Rocks!

    Have ~10 other wordpress plugins working nicely together.

    Not done yet - but...
    Checkout the site: http://firstfreightwp.bitnamiapp.com/wordpress

    Have had to wrangle some ssh vim sessions here & there to edit this & that... Bitnami requires a few bits here & there...

    Have deactivated, removed & re-installed your plugin - to no avail...

    Right then...

    Whatchathink?

    Charles

  4. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Charles,

    Very strange - for some reason the table isn't getting created during install.
    Can you let me know your MySQL version? I can run some tests then.

    Also, if you have access to the MySQL database yourself, with phpMyAdmin or otherwise, you could try running this query which will create the table. It may give back an error too which would be helpful if you could pass it back to me:

    [code]CREATE TABLE wp_wponlinebackup_items (
    bin INT(10) UNSIGNED NOT NULL,
    item_id INT(10) UNSIGNED NOT NULL AUTO_INCREMENT,
    parent_id INT(10) UNSIGNED NOT NULL,
    type SMALLINT(1) UNSIGNED NOT NULL,
    name VARCHAR(255) NOT NULL,
    exists SMALLINT(1) UNSIGNED DEFAULT NULL,
    file_size INT(10) UNSIGNED DEFAULT NULL,
    mod_time INT(10) UNSIGNED DEFAULT NULL,
    backup SMALLINT(1) UNSIGNED DEFAULT NULL,
    new_exists SMALLINT(1) UNSIGNED DEFAULT NULL,
    new_file_size INT(10) UNSIGNED DEFAULT NULL,
    new_mod_time INT(10) UNSIGNED DEFAULT NULL,
    activity_id INT(10) UNSIGNED NOT NULL,
    counter INT(10) UNSIGNED NOT NULL,
    path TEXT NOT NULL,
    PRIMARY KEY (bin, item_id),
    UNIQUE item (bin, parent_id, type, name),
    INDEX browse (bin, parent_id, exists, type, name),
    INDEX activity_id (activity_id, backup, bin, item_id),
    INDEX exists (bin, exists, activity_id)
    );[/code]

  5. pholleman
    Member
    Posted 3 years ago #

    I have the same issues after installing WP 3.2.1. The backup goes through several timeouts before ending. I deleted and re-installed. No difference!

  6. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi pholleman,

    Did it work for you before installing WP 3.2.1?
    What version were you using before that?

    Jason.

  7. outlierdesign
    Member
    Posted 3 years ago #

    The plugin also does not work for me with WP 3.2.1 (I receive the same error as noted above), and I have deleted and re-installed with no success as well.

    The plugin used to work for me on earlier version of WP, though I don't remember which specific version I was using before updating. 3.something.

    I tried running the SQL query you suggested and received the following error:

    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'exists SMALLINT(1) UNSIGNED DEFAULT NULL, file_size INT(10) UNSIGNED DEFAULT NU' at line 7

  8. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi outlierdesign,

    The forum mangled the query (i actually got the code bit wrong :-) too used to BB style). Let me try again:

    (Make sure to change to wp_wponlinebackup_items bit to what it says in the error message after the database name and the period. So if it says wordpress.blog_wponlinebackup_items, change it to blog_wponlinebackup_items)

    Let me know how you get on and if it reports errors about different tables.

    Also, if you could provide the MySQL version that will be great. But running this query manually should throw up any version issue I think.

    CREATE TABLE wp_wponlinebackup_items (
    bin INT(10) UNSIGNED NOT NULL,
    item_id INT(10) UNSIGNED NOT NULL AUTO_INCREMENT,
    parent_id INT(10) UNSIGNED NOT NULL,
    type SMALLINT(1) UNSIGNED NOT NULL,
    name VARCHAR(255) NOT NULL,
    exists SMALLINT(1) UNSIGNED DEFAULT NULL,
    file_size INT(10) UNSIGNED DEFAULT NULL,
    mod_time INT(10) UNSIGNED DEFAULT NULL,
    backup SMALLINT(1) UNSIGNED DEFAULT NULL,
    new_exists SMALLINT(1) UNSIGNED DEFAULT NULL,
    new_file_size INT(10) UNSIGNED DEFAULT NULL,
    new_mod_time INT(10) UNSIGNED DEFAULT NULL,
    activity_id INT(10) UNSIGNED NOT NULL,
    counter INT(10) UNSIGNED NOT NULL,
    path TEXT NOT NULL,
    PRIMARY KEY (bin, item_id),
    UNIQUE item (bin, parent_id, type, name),
    INDEX browse (bin, parent_id, exists, type, name),
    INDEX activity_id (activity_id, backup, bin, item_id),
    INDEX exists (bin, exists, activity_id)
    );

    Jason.

  9. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Nope, it screwed it up again. Whoever wrote the forum wants shooting (not with anything lethal - with something like an indian style bow and arrow - you know, the child ones with a sucker on the end). I have no idea how to type a back tick without it turning into code :\

    Hmm... Maybe if I assume the forum thinks everyone is a coder and I use HTML...

    CREATE TABLE `wp_wponlinebackup_items` (
    `bin` INT(10) UNSIGNED NOT NULL,
    `item_id` INT(10) UNSIGNED NOT NULL AUTO_INCREMENT,
    `parent_id` INT(10) UNSIGNED NOT NULL,
    `type` SMALLINT(1) UNSIGNED NOT NULL,
    `name` VARCHAR(255) NOT NULL,
    `exists` SMALLINT(1) UNSIGNED DEFAULT NULL,
    `file_size` INT(10) UNSIGNED DEFAULT NULL,
    `mod_time` INT(10) UNSIGNED DEFAULT NULL,
    `backup` SMALLINT(1) UNSIGNED DEFAULT NULL,
    `new_exists` SMALLINT(1) UNSIGNED DEFAULT NULL,
    `new_file_size` INT(10) UNSIGNED DEFAULT NULL,
    `new_mod_time` INT(10) UNSIGNED DEFAULT NULL,
    `activity_id` INT(10) UNSIGNED NOT NULL,
    `counter` INT(10) UNSIGNED NOT NULL,
    `path` TEXT NOT NULL,
    PRIMARY KEY (`bin`, `item_id`),
    UNIQUE `item` (`bin`, `parent_id`, `type`, `name`),
    INDEX `browse` (`bin`, `parent_id`, `exists`, `type`, `name`),
    INDEX `activity_id` (`activity_id`, `backup`, `bin`, `item_id`),
    INDEX `exists` (`bin`, `exists`, `activity_id`)
    );

  10. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Well, that worked! Annoying forum lol!
    Damn I hate wiki style crap, OK it makes it easier to make things bold, but blimey does it fight back when you just want to type a damn underscore or a backtick!

    Try that query.

  11. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Damnit! Edited the post, and all of a sudden <br /$gt; appears at the end of all the lines of code (but nowhere else?) and my HTML backticks turned into real backticks, and my turned into backticks too. Blimey this is buggy!

    Anyways, back to the issue at hand - that code is perfect and should work, give it a go and let me know - sorry for the chain posting.

  12. Crazybikerdave
    Member
    Posted 3 years ago #

    Tried that query, and received the following message: "Incorrect table definition; there can be only one auto column and it must be defined as a key"

    Any suggestions?

  13. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Crazybikerdave,

    I think I found the issue.

    Try this:

    CREATE TABLE `wp_wponlinebackup_items` (
    `bin` INT(10) UNSIGNED NOT NULL,
    `item_id` INT(10) UNSIGNED NOT NULL AUTO_INCREMENT,
    `parent_id` INT(10) UNSIGNED NOT NULL,
    `type` SMALLINT(1) UNSIGNED NOT NULL,
    `name` VARCHAR(255) NOT NULL,
    `exists` SMALLINT(1) UNSIGNED DEFAULT NULL,
    `file_size` INT(10) UNSIGNED DEFAULT NULL,
    `mod_time` INT(10) UNSIGNED DEFAULT NULL,
    `backup` SMALLINT(1) UNSIGNED DEFAULT NULL,
    `new_exists` SMALLINT(1) UNSIGNED DEFAULT NULL,
    `new_file_size` INT(10) UNSIGNED DEFAULT NULL,
    `new_mod_time` INT(10) UNSIGNED DEFAULT NULL,
    `activity_id` INT(10) UNSIGNED NOT NULL,
    `counter` INT(10) UNSIGNED NOT NULL,
    `path` TEXT NOT NULL,
    PRIMARY KEY (`bin`, `item_id`),
    UNIQUE `item` (`bin`, `parent_id`, `type`, `name`),
    INDEX `browse` (`bin`, `parent_id`, `exists`, `type`, `name`),
    INDEX `activity_id` (`activity_id`, `backup`, `bin`, `item_id`),
    INDEX `exists` (`bin`, `exists`, `activity_id`)
    ) ENGINE=MyISAM;
  14. Crazybikerdave
    Member
    Posted 3 years ago #

    Awesome! That fixed the issue I was having. Thanks a million for the help & assistance.

  15. Online Backup
    Member
    Plugin Author

    Posted 3 years ago #

    Great! We've packaged this into the next version to stop it happening again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic