WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Online Backup for WordPress] Backups missing lots of files and folders

[Resolved] [Plugin: Online Backup for WordPress] Backups missing lots of files and folders

  • cokeyblokey
    Participant

    @cokeyblokey

    I’d like to start by thanking Driskell for a truly great plug-in. I switched from EZPZ Backup due to lots of issues and find this one to be much more reliable.

    However, I’ve just noticed that the backups i’m doing on two of my WP sites, are much smaller than usual. On further investigation it seems that only the wp-content folder is getting backed-up. It’s missing wp-admin and wp-includes folders as well as most of the root files. These were always getting included in the back-up until now.

    This is happening on two separate sites, on two separate hosts.

    What’s going on????

    I’ve not updated WP, nor the plug-in.

    I’m hoping Driskell can help out and I can see that I’m not the only one experiencing this problem.

    http://wordpress.org/extend/plugins/wponlinebackup/

Viewing 15 replies - 1 through 15 (of 20 total)
  • cokeyblokey
    Participant

    @cokeyblokey

    just to add..

    The backups types i’m doing are manual download backups.

    I can’t help with your issue specifically, but is there a particular reason you need those files backed up?

    The database and the wp-content folder are the most important and really all you need to restore the site if anything goes wrong.

    cokeyblokey
    Participant

    @cokeyblokey

    Thanks Defime, I realise that. The thing is, one of the sites is currently on a development server – having a FULL backup easily enables me to move it to it’s live environment when ready. Yes I realise I don’t need WP Online Backup to be able to achieve this, but I like the simplicity of this plug-in and it cuts out a load of steps I would have to perform with cPanel and phpMyadmin.

    Furthermore, I’m now finding the backup doesn’t contain my custom theme – so it’s now useless.

    UPDATE: I’ve just deactivated, deleted, reinstalled and activated the plug-in again. Now I have a full back-up! I’ve tried the back-up process 3 times now, deleting the previous one as I go and it’s worked everytime. Wish I had of tried this earlier.

    My advice to anybody experiencing problems – delete the plug-in and then reinstall and activate again.

    cokeyblokey
    Participant

    @cokeyblokey

    Well, unfortunately I’ve had to remove the ‘Resolved’ status.

    I’m still getting the same problems. Deleting the plugin then re-installing works for a short while but after a few back-ups I start getting missing files and folders again. This happens on all 3 sites I’m using it on. The missing folders vary from back-up to back-up.

    Nothing is ticked to be excluded and I’ve also checked the advanced settings mentioned by Jason in another post.

    Jason – if you want me to give you access to one of the sites, so you can see the problem yourself, then let me know.

    Plugin Author Online Backup
    Member

    @driskell

    Hi cokeyblokey.

    Sorry for the late response for this. The way the forum records support topics seems to have changed.

    Are you performing a download backup? Or scheduling a daily emailed backup?
    Is it the same files missing each time, or no particular pattern?

    Regards,

    Jason.

    cokeyblokey
    Participant

    @cokeyblokey

    Hi Jason,

    Thanks for getting back to me on this.

    It’s the manual, download backups I’m having problems with – haven’t yet tried scheduled daily email backup.

    There doesn’t seem to be too much of a pattern in what’s missing from the backups. For instance, I’ve just performed a full back-up and the zip come in at just over 2MB (should be in the region of 12MB). This one is missing half the root files (html and php) as well as the ‘wp-admin’ and ‘wp-includes’ folders. The ‘wp-content’ folder is missing lots and only contains the ‘themes’ and ‘plugins’ folders – the ‘plugins’ folder is missing all but two of them.

    Then I performed the same back-up straight after and this time it came in at just over 6MB but still missing lots. Root files all seem to be there and all 3 WP folders are present but ‘wp-contents’ is still missing the all important ‘uploads’ folder and ‘plugins’ still missing all but 2.

    If I deactivate, delete and reinstall then the back-up will be perfect. I can do the back-up time after time, in quick succession and all will be fine but if I come back the next day then it’s all gone wonky again!

    Let me know what you think
    Thanks
    Marc

    Plugin Author Online Backup
    Member

    @driskell

    Hi Marc,

    Does the event log for the backup say anything about items excluded or items skipped due to errors?

    I’ll take a look through code see if I can find a reason for this and also update our tracing version that we can use if we can’t find anything.

    Jason.

    cokeyblokey
    Participant

    @cokeyblokey

    No, nothing in the logs concerning excluded or skipped items. I do have a folder added to the custom exclude but I get the same results whether this is excluded or not.

    Plugin Author Online Backup
    Member

    @driskell

    Hi Marc,

    Can you drop an email to support “at” backup-technology.co.uk and post a link to this forum topic. I’ll get someone to send over a tracing version you can run which will produce a log file for us.

    Thanks,

    Jason

    Plugin Author Online Backup
    Member

    @driskell

    Hi Marc,

    Apologies for the delay. The tracing version is ready and we’ve emailed it to you with information in the email.

    Thanks,

    Jason.

    Plugin Author Online Backup
    Member

    @driskell

    Hi Marc,
    Did you manage to get a trace log from the second trace version I sent over?
    Thanks,
    Jason.

    cokeyblokey
    Participant

    @cokeyblokey

    Hi Jason,

    I’ve had the version you sent over installed for about a week now. I’ve done a few manual backups and the problem has not yet come back. I’ll continue to monitor and let you know if and when it goes wrong.

    Thanks
    Marc

    Plugin Author Online Backup
    Member

    @driskell

    Thanks Marc

    cokeyblokey
    Participant

    @cokeyblokey

    Hi Jason,

    The problem has resurfaced. I’ve not needed to back up the site for a few weeks, but I did a backup just a minute ago and the backup filesize has dropped from 25MB to 5MB. The ‘wp-content’ folder is missing everything except the ‘uploads’ folder, although thats missing folders too.

    I’ve just emailed you the trace.log file.

    I have the same problem. It doesn’t back up many of the files I have in the wp-content folder. My theme folder is empty, and there is only one folder under my theme folder which is “Cache” folder with a lots of txt files. None of the php files are getting backed up in my theme’s folder.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] [Plugin: Online Backup for WordPress] Backups missing lots of files and folders’ is closed to new replies.