Support » Plugin: Online Backup for WordPress » [Plugin: Online Backup for WordPress] An online request succeeded but was malformed.

  • Resolved zaheer22

    (@zaheer22)


    Hello,

    I think this is a great plugin, Once i am able to make it work reliably 🙂 I found one problem with “receiving junk from your blog” was fixed by excluding the W3 total cache caches, from wp-contentt/w3tc . This solved a lot of my errors that I was seeing in the activity log. However it still fails with this :

    “The backup failed: Communication with the online vault failed.”
    “An online request succeeded but was malformed.”
    “Failed at: /var/www/wordpress/wp-content/plugins/wponlinebackup/include/transmission.php(244)”

    My username is just “zaheer”

    I am using CloudFlare, and W3 total cache, but as noted above i fixed all errors related to cacheing, Any suggestions to bring this amazing plugin to a functional level would ne GREATLY appreciated.

    http://wordpress.org/extend/plugins/wponlinebackup/

Viewing 15 replies - 61 through 75 (of 76 total)
  • Running updated one now…

    Plugin Author Online Backup

    (@driskell)

    That one worked it seems. Can you let it run a few times, maybe hourly? I’ll take a look at logs tomorrow then and hopefully it will pop up again with the junk error. Or you could run a couple manuals first.

    Success on 10 Min backup (manual). That seems normal. I will leave it on hourly to see if there are any more Junk blog, or 4 hr run times.

    Plugin Author Online Backup

    (@driskell)

    Thanks zaheer. Strange how all of a sudden it started working when I changed a single line! Just makes it harder to fix. I’m really looking forward to squashing this one 🙂

    Plugin Author Online Backup

    (@driskell)

    Seems to be two issue. One is causing the script to exit unexpectedly I think – this would explain the long running times which I think you will still see as I’ve not found the source of this yet. It is also causing the conditions for the second issue.

    The second issue is a failure to handle the previous issue above correctly and it actually makes things worse and results in the junk error. I’ve fixed this internally but not in the dev as the junk error is a good way to dump junk to the server… such as diagnostics as it sees the result of the previous issue. If I fix this the backup would complete successfully but you’d probably still have the long running ones periodically.

    Could you try to dig out error logs for your server at all? I wonder if an error is happening which we can’t see. It might be error_log file in your FTP logs folder or HTML folder or maybe hidden in control panel somewhere. I think definitely worth a look if you have a moment.

    Thanks

    Wow check this out :

    3rd May 2012 6.04.35 PM 3rd May 2012 6.09.55 PM 5 m 20 s Successful 195.75 KiB (1 file) 76.8 MiB (4779 files) View Events (13)
    3rd May 2012 4.00.55 PM 3rd May 2012 4.04.26 PM 3 m 31 s Successful 196.05 KiB (1 file) 76.8 MiB (4779 files) View Events (12)
    3rd May 2012 3.03.32 PM 3rd May 2012 3.30.18 PM 26 m 46 s Successful 196.17 KiB (1 file) 76.8 MiB (4779 files) View Events (12)
    3rd May 2012 2.43.47 PM 3rd May 2012 2.46.29 PM 2 m 42 s Successful 196.17 KiB (1 file) 76.8 MiB (4779 files) View Events (12)
    3rd May 2012 2.40.14 PM 3rd May 2012 2.42.53 PM 2 m 39 s Successful 196.17 KiB (1 file) 76.8 MiB (4779 files) View Events (12)
    3rd May 2012 2.26.26 PM 3rd May 2012 2.36.23 PM 9 m 57 s Successful 2.96 MiB (399 files) 76.8 MiB (4779 files) View Events (14)

    26 Min is a bit much, but the rest seem normal. Think there is still an issue i can help track down? , Will leave it on hourly the rest of the night to see how things shake out.

    The 26 minute one :
    3rd May 2012 3.30.16 PM Information Retention was not required, you are still within your maximum quota.
    3rd May 2012 3.30.16 PM Information The online vault has successfully processed the backup data.
    3rd May 2012 3.30.16 PM Information Transmission of the backup data to the online vault has completed.
    3rd May 2012 3.03.42 PM Information Deleted files processing completed.

    As you can see the backup was only 196KB, no reason to take that long, seemed to occur int he transmission stage (weird) .

    Plugin Author Online Backup

    (@driskell)

    Hi zaheer,

    Dropped you an email yesterday or day before with a new version with some logging in it, that has a bit more detail and a few tweaks that might fix it. The issue does seem completely reproducible on each backup session but for the most part it is not affecting the backup but sometimes it does cause the junk errors, so the junk symptom is quite intermittent but the logs definitely say the issue is constantly happening.

    Let me know when you can put the newer version on.

    Thanks,

    Jason

    I threw it up right when you sent it 🙂 I’ve had multiple successfuls but also a few “6 hr” backups. I think you mentioned the logs are available over http so i would expect you can see them now?

    Plugin Author Online Backup

    (@driskell)

    Hi Zaheer,

    I sent over another a while after the first. Did you definitely replace with the newer? Can you check your mailbox? I responded to the email that had a snapshot in it. I can send again if need.

    Jason

    Plugin Author Online Backup

    (@driskell)

    I sent the newer again. I think you updated the old one again though just now as the log file reset. Just so you know.

    I should learn to tag the filename do we can tell the difference lol sorry!

    Any updates on this saga?

    Plugin Author Online Backup

    (@driskell)

    Hi zaheer,

    I did a one-fits-all for MySQL caching systems and read/write splitters, which also fixes issues caused by persistent connections etc.

    Send it to your email, if you can give that one a go and I’ll check the logs to see if we successfully worked around the issue.

    Thanks,

    Jason

    Plugin Author Online Backup

    (@driskell)

    Hi Zaheer,

    First backup… 🙂 worked a charm, NO symptoms.
    Its early days though I’ll keep an eye out next few days and let you know how it goes and I’ll start wrapping up the version for release, pending these results of course!

    Thank you very much for the help. It feels close to the end of this issue now 🙂

    Jason

    Hey Jason,

    Left it on hourly, 17 Backups went with NO issues. better yet, None of that 3-4 hour backup stuff. Every backup completed in under 2 minutes!. 🙂 I will leave it on hourly for one more day, but I really think your sorted it! 🙂

Viewing 15 replies - 61 through 75 (of 76 total)
  • The topic ‘[Plugin: Online Backup for WordPress] An online request succeeded but was malformed.’ is closed to new replies.