Support » Plugin: Cloudflare » Plugin not working with php v7.1.11

  • Resolved svayam

    (@svayam)



    Hello,

    I have been using Cloudflare for a while and really loving the experience.

    But unfortunately I have to go to CF dash board every-time to Purge changes and to see the analytics dashboard. I tried to use this plugin but unfortunately it’s not working with PHP 7.1.11.

    After activating, there is just a blank page and simply nothing else. If you kindly upgrade this plugin to make it work with the latest PHP version and also with the Latest WordPress Version 4.9 which is about to roll out within a few hours.

    It would be really helpful for all of us who are using the wonderful Cloudflare platform. Thanks in advance.

    Kind regards,

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author thellimist

    (@furkan811)

    Hi @svayam,

    I’ve tested the plugin with WordPress Version 4.9 and I can assure that the plugin works as intended. The plugin should work with PHP 7.1.11 as well. Your problem might be caused by something else.

    Could you provide the browser console logs?

    Thanks

    svayam

    (@svayam)

    Hi,

    Thanks for your reply. Well can you please guide me on how to get the browser console logs? So I can send you.

    Thanks you.

    svayam

    (@svayam)

    Hello,

    I have disabled the caching plugin, minification, any type of optimisation before copying this log.

    The following is the log perhaps this you asked for. Let me know if any other things I can provide. I have marked bold for 1 404 error which was marked red in the console.

    [ SNIP ]

    Kind regards,

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    @svayam Posting logs here doesn’t work past ~10 lines or so.

    Please use pastebin.com instead and share the link to that paste.

    svayam

    (@svayam)

    Hello,

    Thanks for the guidance, here is the link to the code.

    https://pastebin.com/cHSbQ9MA

    Thank you for the help. Hope to find a solution soon!

    Kind regards,

    Plugin Author thellimist

    (@furkan811)

    Hi @svayam,

    /wp-content/plugins/cloudflare/config.js?ver=3.3.1 Failed to load resource: the server responded with a status of 404 ()
    

    Other users have seen the same error. I recommend you checking this post https://wordpress.org/support/topic/cloudflare-login-panel-not-showing-up/

    Thanks

    svayam

    (@svayam)

    Hi,

    I found the problem, it’s due to the All in One WP Security & Firewall, which is blocking the script under ” Advanced Character String Filter”.

    Is there any way to make an exception to the htaccess for this?

    Thanks

    Plugin Author thellimist

    (@furkan811)

    I have never used One WP Security & Firewall plugin. You may want to ask in there support forum.

    I’m marking the issue as Resolved.

    Thanks

    svayam

    (@svayam)

    Thank you so much for the guidance. everything seems to work fine now.

    Kind regards,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Plugin not working with php v7.1.11’ is closed to new replies.