Support » Plugin: Ultimate WooCommerce Filters » Plugin not working properly: product search page empty

  • Resolved oyin

    (@oyin)


    Hello,

    I’m currently using your plugin for my WooCommerce website. However, after adding the color swatches and including it in all my products, it doesn’t work.

    Whenever I try testing by filtering the colors on the shop page, it turns up “No products were found matching your selection” error.

    Can you help with this?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Hi oyin,

    I just tested and the plugin seems to be working correctly for that functionality, which is the base functionality of the plugin. Maybe there’s an incorrect setting or something isn’t configured properly on your end. If you could provide a link to your shop page, perhaps it might give us some kind of indication of where the problem lies.

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Hi @oyin,

    I noticed in your URL, upon clicking on a color to filter your products, the following query string gets appended: min_rating=undefined&max_rating=undefined.

    Which option is selected for the “Reviews to Use” option (right under where you unable the ratings filtering)? If you don’t have the Ultimate Reviews plugin enabled, then make sure this is set to WooCommerce (even if you have the ratings filtering option disabled).

    That being said, the URL parameters showing up when you have the ratings filtering disabled would seem to indicate to me that there’s some kind of issues with your ratings/reviews settings in WooCommerce itself. Do you have ratings/reviews enabled in WooCommerce? If so, are you using them? Because, if you aren’t, you should disable them.

    If you do have and want them enabled, what do you have checked for the five options WooCommerce gives you there?

    Hello @etoilewebdesign,

    I noticed the query string too. I’ve disabled my WooCommerce Reviews, even made a few tweaks with the source code but it’s still the same.

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    I’m not sure what to tell you. If you’re getting that in the URL, then there’s an incorrect setting somewhere related to your WooCommerce reviews.

    I got the same problem. URL is having same parameters
    product_color=verdi-irish&min_rating=undefined&max_rating=undefined

    But if you use only this /?product_color=verdi-irish it work ok.
    I have disable review options and still getting the same.

    Not working-
    https://standard-wear.com/shop/?product_color=verdi-irish&min_rating=undefined&max_rating=undefined

    Working Without all the parameters
    https://standard-wear.com/shop/?product_color=verdi-irish

    Anything I can do?
    Thank in advance.

    I believe that, this problem is not solved and that the fault is of the plugin and not of the reviews of WooCommerce.
    When you only activate the color option, the plugin adds the string (previously mentioned) to the URL, making it impossible to perform the correct search.
    When I activate the reviews option, the correct URL is loaded.
    However, by enabling the reviews option, the search option is activated and even if I disable it, it is automatically re-enabled.
    Thank you for your help!

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Just to let you know, we released an update that will help to remove those strings from the address bar if you have the ratings filters enabled and that is happening. Please update to the new version of the plugin.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugin not working properly: product search page empty’ is closed to new replies.