Support » Plugin: Easy FancyBox » Plugin not working post update

  • Resolved royz4u

    (@royz4u)


    Hello Team,
    The plugin seems to stop working post update to the latest version.
    Click on any of the links from the page provided. It opens in the new tab instead.
    Looking forward to a quick solution.
    Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author RavanH

    (@ravanh)

    Hi, it’s hard to see what is going wrong as long as the fancybox scripts are being minified/concatenated by your cache plugin. Or are that more than one caching plugins? I notice stamps from both WP Super Cache and W3 Total Cache. And the concatenated scripts are loaded from a directory called cache/fvm … is that W3TC too?

    First, your server supports HTTP/2 (see https://tools.keycdn.com/http2-test for example) so there really is not much to gain by concatenating scripts. It might in fact be a disadvantage to do concatenation and not take advantage of HTTP/2 parallel requests… My guess is that once concatenation is turned off, or at least the fancybox scripts are excluded from that process, the light box effect will start working again.

    Next, consider NOT using WP Super Cache and W3TC together. Choose one of the two, or even another caching plugin (like Hummingbird) to do the task on its own. Multiple plugins competing for the same task on one WP installation is never a good idea.

    royz4u

    (@royz4u)

    Hello @ravanh ,
    Thank you very much for your response.Here’s what we are using:
    1. Cache – we installed W3Total Cache once but uninstalled it then and there because it was giving issues. Now wer are using WP Super Cache for quite a while and the site was working fine with it.

    2. Regarding Minification – We also had ‘Fast Velocity Minify’ plugin which was also running parallelly for sometime without any issues

    2. Recently we have added a3 Lazy Load Plugin and after which we had an updated of the Easy FancyBox. After which it stopped working.

    We will try to check the folder you mentioned and deactivate W3 Super Cache and see if that works!
    Looking forward to your response meanwhile.
    Thank you very much once again!

    Plugin Author RavanH

    (@ravanh)

    OK I was just thinking W3TC was still active because there is a stamp <!-- W3TC-include-js-head --> in your page source code all the way at the end, near the WP Super Cache stamp.

    Easy FancyBox should be fully compatible with WP Super Cache but I understand that all scripts are being concatenated and compressed by Fast Velocity Minify? Try deactivating that plugin or at least turn off concatenation (the part that mashes all scripts into one file) because with HTTP/2 you do not need that… If you want to compress your scripts, then exclude all fancybox scripts and stylesheet as they are already minified.

    royz4u

    (@royz4u)

    @ravanh That worked!
    I deactivated the ‘Fast Velocity Minify’ plugin and it did the job.
    Just wondering that it (Fast Velocity Minify) was still there since the beginning but why there wasn’t any problem then?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plugin not working post update’ is closed to new replies.