Support » Plugin: Contact Form 7 Extension For Mailchimp » plugin not working on some forms

  • The ajax icon is spinning infinite on some forms if your plugin is activated. wordpress and contact form 7 has version 4.8.1.

    the console logs an internal server error 500:

    jquery.js?ver=1.12.4:4 POST http://xxxxxxx.xxx/wp-json/contact-form-7/v1/contact-forms/275/feedback 500 (Internal Server Error)
    send @ jquery.js?ver=1.12.4:4
    ajax @ jquery.js?ver=1.12.4:4
    wpcf7.submit @ scripts.js?ver=4.8.1:326
    (anonymous) @ scripts.js?ver=4.8.1:53
    dispatch @ jquery.js?ver=1.12.4:3
    r.handle @ jquery.js?ver=1.12.4:3

    i got this problem on multiple websites, please fix this!

    • This topic was modified 2 years, 3 months ago by fruchtfliege.
Viewing 1 replies (of 1 total)
  • Hey @fruchtfliege,

    I just stumbled upon what appears to be the same (or at least very similar) issue and after a lot of troubleshooting, I discovered that since PHP error reporting was on, there was a PHP Warning about missing arguments and the HTML for that warning was being returned instead of valid JSON. After I set the following in the wp-config.php file, my forms started submitting normally again.

    
    define('WP_DEBUG', false);
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    

    It may or may not be a solution to your specific issue but since I consistently found this post in my trip through Google searches, I figured it couldn’t hurt to provide a potential solution.

    Hope it helps!

    -Craig

Viewing 1 replies (of 1 total)
  • The topic ‘plugin not working on some forms’ is closed to new replies.