Support » Plugin: Contact Form 7 - PayPal & Stripe Add-on » Plugin not working / Not redirecting to paypal

  • Resolved flewid



    I see all the other posts about the plugin not working and I’ve tried all the suggestions;

    1. uninstalled cf7
    2. uninstalled paypal plugin
    3. reinstalled both
    4. hit ‘save’ on all possible settings screens (cf7, paypal tab, forms)
    5. made sure cf7 and paypal are at latest versions
    6. checked server logs (there is nothing regarding this)
    7. created a brand new test form with paypal support, still doesn’t redirect
    8. disabled wordfence just incase
    9. no other recent changes made to site
    10. tried on basic twentytwenty theme
    11. submitted url has #wpcf7-f1459-p4806-o1 appended to it, which is unusual
    12. watched chrome console, nothing weird in it

    really not sure what else to try, this is a pretty big showstopper to happen on a live site.

    any help would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Scott Paterson


    What version of Contact Form 7 are you using?
    Do you have any other Contact Form 7 add-ons active on your site?
    Are you using any caching plugins?

    Thread Starter flewid


    Hey Scott,

    Thanks for the reply. So

    – I was using the latest version of CF7, I also tried to downgrade to the prior version, and, his development version (note: don’t do this, lol downgrading deletes all your forms for some dumb reason).

    – I do not have any other CF7 addons active on the site.

    – Do not have any caching plugins.

    – I do have opcode and apc enabled on apache, however I flushed those caches, and also restarted apache just to be sure and did not make a difference.

    – I also flushed apaches cache, and there is nothing in it now

    htcacheclean -A -p /var/cache/apache2/mod_cache_disk

    – Only thing that exists in my htaccess is the standard wordpress stuff;

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Plugin Author Scott Paterson


    Thanks for the details.

    Due to the new version of Contact Form 7, the plugin now uses PHP Cookies. Which it looks like may not play nice with all server side caching. I’m going to see if there is another way I can code the plugin to fix this.

    Thread Starter flewid


    Also, upgraded back to latest CF7 – 1.6.5 – same deal

    Thread Starter flewid


    interesting – can i disable caching for just one site (i run multiple vhosts)

    Thread Starter flewid


    tried this in htaccess just to see


    <IfModule mod_headers.c>
    Header set Cache-Control “no-cache, no-store, must-revalidate”
    Header set Pragma “no-cache”
    Header set Expires 0

    <FilesMatch “\.(css|flv|gif|htm|html|ico|jpe|jpeg|jpg|js|mp3|mp4|png|pdf|swf|txt)$”>
    <IfModule mod_expires.c>
    ExpiresActive Off
    <IfModule mod_headers.c>
    FileETag None
    Header unset ETag
    Header unset Pragma
    Header unset Cache-Control
    Header unset Last-Modified
    Header set Pragma “no-cache”
    Header set Cache-Control “max-age=0, no-cache, no-store, must-revalidate”
    Header set Expires “Thu, 1 Jan 1970 00:00:00 GMT”


    did not work

    Thread Starter flewid


    We ended up moving to Gravity Forms + Woocommerce as it was very urgent for us to get this resolved. Thanks for the help anyway.

    Has this issue been fixed yet? I have the same problem with PHP Sessions that were described.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin not working / Not redirecting to paypal’ is closed to new replies.