Support » Plugin: Amazon SES DKIM Mailer » Plugin Not Working After Upgrade to 1.4

Viewing 9 replies - 1 through 9 (of 9 total)
  • Also, I am using the most recent WordPress version, 3.5.2.

    Anyone have any ideas on this?

    Plugin Author Roger MacRae

    (@rmac0001)

    try uninstalling and reinstalling the plugin

    Hi, I’ve just upgraded to the latest version and I’m getting the same issue. The error in Apache’s error log is as follows

    PHP Fatal error: Call to undefined method PHPMailer::IsAmazonSES() in /var/www/ianxharris/wp-content/plugins/amazon-ses-and-dkim-mailer/configure-smtp.php on line 380, referer: http://ianxharris.co.uk/wp-admin/options-general.php?page=amazon-ses-and-dkim-mailer%2Fconfigure-smtp.php&settings-updated=true

    I’ve checked in the classes and these methods don’t seem to be there.

    Any ideas anyone?

    The IsAmazonSES function is missing from class.phpmailer.php in both 1.4 and 1.5. In 1.3, it’s this:

    /**
       * Sets Mailer to send message using Amazon Simple Email Service(SES).
       * @return void
       */
      public function IsAmazonSES() {
        $this->Mailer = 'amazonses';
      }
    Plugin Author Roger MacRae

    (@rmac0001)

    sorry folks, this was an oversight. The issue is fixed now. Please update to version 1.6

    Awesome. Thanks, Roger. Installed and it looks to be working now. Thanks a ton for this plugin!

    Do you have anywhere we can donate, etc?

    Ben

    Cool, installed and working too. I’m getting a spurious error at the top when I use the test but all comment emails etc are working. If you want the error I’m seeing with the test it’s as follows:

    An error was encountered while trying to send the test e-mail.
    
    AmazonSES Error: 0000013fee6883a7-76d88286-fe34-48c4-8574-fd767946be80-000000 e6166505-ef22-11e2-83b8-f1b458495c98

    Thanks again for the quick fix.
    Ian

    Plugin Author Roger MacRae

    (@rmac0001)

    yeah that error is not an error. I am trying to track down why it is showing as it doesn’t happen every time

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Plugin Not Working After Upgrade to 1.4’ is closed to new replies.