WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Plugin not working after Thesis update

[Resolved] Plugin not working after Thesis update

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author JS Morisset

    @jsmoriss

    Hi, i unchecked the filters options and the problem is not solved.

    Activating debug mode i have these errors:

    [Error] TypeError: 'null' is not an object (evaluating '/^[^?#]*\//.exec(location.href)[0]')
    	(función anónima) (LAB.js, line 18)
    [Error] Failed to load resource: the server responded with a status of 503 (Service Unavailable: Back-end server is at capacity) (log.pinterest.com, line 0)
    [Error] TypeError: 'null' is not an object (evaluating '/^[^?#]*\//.exec(location.href)[0]')
    	(función anónima) (LAB.js, line 18)
    [Error] Blocked a frame with origin "http://www.facebook.com" from accessing a frame with origin "http://www.cruzgloriosa.org". Protocols, domains, and ports must match.
    [Error] Blocked a frame with origin "https://www.facebook.com" from accessing a frame with origin "http://www.cruzgloriosa.org".  The frame requesting access has a protocol of "https", the frame being accessed has a protocol of "http". Protocols must match. (x2)
    
    [Error] Unable to post message to http://www.stumbleupon.com. Recipient has origin http://www.cruzgloriosa.org.

    And these warnings:

    [Warning] The "fb-root" div has not been created, auto-creating (all.js, line 56)
    [Warning] Invalid CSS property declaration at: * (tweet_button.1386967771.html, line 1, x3)

    Plugin Author JS Morisset

    @jsmoriss

    You’ll have to provide a URL to an example page. 😉

    js.

    Yes, yes… but the problem is in my home page, then i deactivated the plugin because the visitors can’t view important information with this problem…

    It’s possible to send me a message when you can to see my page for activate temporally the plugin.

    Thanks

    Plugin Author JS Morisset

    @jsmoriss

    FYI – The errors you posted come from the various social JavaScripts, which are coded and supported by the various social websites themselves.

    What you can do is add the following to your wp-config.php file. Activate the plugin, reload the page, deactivate the plugin, remove/comment the code, and finally, provide a URL to the resulting debug.log file. Do not post the debug.log file here – it will be too large.

    define('WP_DEBUG', true);
    if ( defined('WP_DEBUG') && WP_DEBUG == true ) {
        define('WP_DEBUG_LOG', true);
        define('WP_DEBUG_DISPLAY', false);
        @ini_set('display_errors',0);
    }
    define('NGFB_WP_DEBUG', true);
    define('NGFB_HTML_DEBUG', true);

    js.

    Ok.

    The debug.log file is here:
    http://www.cruzgloriosa.org/public/tmp/debug.log

    Plugin Author JS Morisset

    @jsmoriss

    The debug.log looks fine.

    Download and install the next version from http://downloads.wordpress.org/plugin/nextgen-facebook.6.19rc1.zip.

    Then you can try adding the following constants to try and narrow down which feature is causing the conflict. **Only use one at a time**.

    define( 'NGFB_META_TAGS_DISABLE', true );
    
    define( 'NGFB_OPEN_GRAPH_DISABLE', true );
    
    define( 'NGFB_SOCIAL_SHARING_DISABLE', true );

    Let me know which one makes a difference.

    js.

    Hi,

    Thanks.

    How i do to install this new version? I delete the old version from plugins page or i rest with two versions installed?

    Thanks a lot.

    Plugin Author JS Morisset

    @jsmoriss

    Edited:
    Hi,

    I don’t have error with this option:
    define( 'NGFB_SOCIAL_SHARING_DISABLE', true );

    but the social buttons not are presents in posts and pages…

    With other two options i have problems into my homepage.

    Thanks.

    Plugin Author JS Morisset

    @jsmoriss

    Two? Nope – you should have one – v6.19rc1.

    Defining NGFB_SOCIAL_SHARING_DISABLE fixed the issue?

    js.

    Using:
    define( 'NGFB_SOCIAL_SHARING_DISABLE', true );

    i can see my homepage normally, but i don’t have the social buttons in posts and pages… You can see any posts or pages into: cruzgloriosa.org

    Plugin Author JS Morisset

    @jsmoriss

    Well, that’s very interesting…

    Ok, so next you should remove that constant.

    Uncheck all buttons on the content/excerpt/etc. on the Social Sharing settings page.

    Uncheck all ‘Include on Post Types’ options.

    Then re-check the ‘Include on Post Types’ options one by one and see if your slider breaks.

    Then re-enable each social button one by one, and see if your slider breaks.

    Let me know how far you get. 😉

    js.

    Hi,

    That works now, i check only the “Content” option in all social buttons, i uncheck the “Excerpt” and “Edit” option.

    When is necessary the “Excerpt” option?

    Plugin Author JS Morisset

    @jsmoriss

    Excerpts are summaries for the content, which some themes display on index pages.

    Closing the thread.

    js.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] Plugin not working after Thesis update’ is closed to new replies.