Support » Plugin: AnyWhere Elementor » Plugin Not Working after Latest Updates to it and Elementor

  • Resolved restalfep

    (@restalfep)


    After the latest plugin updates for Anywhere Elementor / Pro and Anywhere Elementor & Pro, we are getting the following error:

    Notice: Trying to get property ‘ID’ of non-object in /wp-content/plugins/MTUyNjUwNzYzMjo4MDc5ZjYwMDZhYTI1ZGNhN2JjYmEwMWU1YWE5MjAxYToyMTpjNzEwM2Q0NGQzZGUwOWNlZTkwZmUwOTJmMTQ2YTA2NTpodHRwc0AvL3d3dy5kZXYuZWxpbWlkcm9sLmNvbTow-TQ40dU/includes/helper.php on line 409

    It says this repeatedly in the error logs. When I go to that folder it shows Anywhere Elementor Pro files. And Line 409 in that file is:

    $img_src = wp_get_attachment_image_src(get_post_thumbnail_id($post->ID),$image_size);

    What is causing this problem? And why is Anywhere Elementor Pro using a random directory name like that under plugins?

    Please let us know ASAP as we need this fixed to migrate our site over.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author webtechstreet

    (@webtechstreet)

    Hi @restalfep

    We are releasing an update tomorrow and it will fix both the issues.

    Folder name got changed with our last update due to some issue in our setup zip file. We have already fixed it and you can download the latest corrected zip from our site.

    Regarding those notices, they will be fixed in next update that we will be releasing tomorrow.

    Apologies for all the inconvenience caused.

    Before your response I renamed the folder back to anywhere-Elementor-pro and deactivated then reactivated the plugin. That seems to have worked even without downloading your latest zip. Is that safe? Or should I change the folder name back and download your zip?

    I just don’t want the update tomorrow to accidentally break it.

    Plugin Author webtechstreet

    (@webtechstreet)

    No there won’t be any issue. Make sure to name it “anywhere-elementor-pro”
    (all small).

    Great! Thanks for your help and the great plugin.

    On a quick side note, we try to minimize plugin usage for all of wordpress as much as possible. Do you know how much impact Anywhere Elementor Pro has on resource usage so we know if it affects speed at all. With the Elementor Pro 2.0 addition having some of the features we were trying to compare but really like using Anywhere Elementor Pro instead.

    On my side it still seems to be messing up with these errors. I updated to the latest version 2.8.2 and this didn’t resolve. I also checked if the plugin folder name is correct and it indeed is.

    Any ideas? I am a Pro user.

    Thanks

    Hi

    Please send a support request here will full detail about the issue.
    https://shop.webtechstreet.com/support/

    anywhere elementor pro

    I’m getting error in the “customize” (visual side) its not displaying the site in visual mode. it throws this error::

    Fatal error: Call to a member function is_preview_mode() on null in /—-/public_html/wp-content/plugins/anywhere-elementor-pro/includes/bootstrap.php on line 326

    Plugin Contributor Hemant Tejwani

    (@tejwanihemant)

    @lonataylor, Please send a support request with some more details at support@webtechstreet.com
    Our team will assist you on this.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin Not Working after Latest Updates to it and Elementor’ is closed to new replies.