• Resolved collinslad

    (@collinslad)


    This plugin doesn’t work on my blog. It sticks at the “Initializing” stage.

Viewing 8 replies - 1 through 8 (of 8 total)
  • lostpine

    (@lostpine)

    I have the same issue. My site is a 940+ page site. I have tried to both create a full PDF and filter a PDF by categories as well as tags. It just spins. Yet I tried the plugin on another smaller blog I support and it works just fine. If filtering worked, this plugin would be perfect for my intended use, education.

    Plugin Author Michael Nelson

    (@mnelson4)

    Hi @collinslad and @lostpine, sorry to hear you’re both having trouble. That’s disappointing, but I’m pretty confident we’ll be able to figure out what’s going wrong. I just double-checked its working on my setup, so it’s likely a conflict with another plugin or your theme (eg like one of these ones from the FAQ).

    @collinslad could you please send me the URL of your site that’s having trouble (with Print My Blog active)? If the plugin is active I’ll be able to debug what’s going on.

    Also, thanks for chiming in @lostpine, especially with sharing your use-case. To help keep the discussion organized, could you please create a new support topic and likewise provide the URL of the site where you’re having the problem? (Again, with Print My Blog active, so I can debug the problem you’re having.)

    We’ll get this sorted out!

    Thread Starter collinslad

    (@collinslad)

    Hi Michael – here’s the url of the site – the plugin is activated: https://isharedthat.com/

    Plugin Author Michael Nelson

    (@mnelson4)

    Awesome thanks @collinslad.
    I’m seeing the error, and after a little voodoo I found a setting in Autoptimize that’s triggering this: under “Javascript options”, disable “Add try-catch wrapping” (here’s a screenshot). I found that when I activated Autoptimize and turned that setting on, Print My Blog didn’t work for me either, but when I disabled it everything worked fine again.

    Does that make sense?

    @lostpine – I do not have such a setting on my site. Is the Autoptimize a site feature or plugin?

    Plugin Author Michael Nelson

    (@mnelson4)

    Hi @lostpine, you’re not going crazy! My last comment on this thread applied only to @collinslad, we’ll debug your problem on the separate support topic you started (his can be fixed by changing that setting in Autoptimize, yours is something different we’re discussing on your topic.)
    @lostpine you might want to unfollow this topic, as his issue has a different cause than yours, and my comments on this topic only apply to @collinslad ‘s problem.
    I hope that makes sense!

    Thread Starter collinslad

    (@collinslad)

    Sorry for the delay Michael – your suggestion has worked and the plugin is working properly now.

    This is a great plugin!

    Thanks very much for your help.

    Plugin Author Michael Nelson

    (@mnelson4)

    Great to hear we got it fixed! I’m investigating to see if I can get Print My Blog to work even with Autoptimize’s “Add try/catch” setting.
    And thanks for the encouragement!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.