Support » Plugin: Q2W3 Fixed Widget for WordPress » Plugin not working

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Max Bond

    (@max-bond)

    Hi!
    Did you check minimal requirements for the plugin?

    You need jQuery 1.7 (better to use 1.10.2 shipped with WP 3.6.1).
    On your site I see jQuery 1.6.2 loaded by theme.

    May be there are other problems, but cannot tell more because you have disabled the plugin…

    Thank you for you help.

    I’m sorry, I already activated the plugin, can you please check again?

    Plugin Contributor Max Bond

    (@max-bond)

    First of all you need to change jQuery version.
    Disable jQuery 1.6.2 loaded by theme.
    Use default WordPress jQuery 1.10.2!

    The plugin should work, if not I’ll check site again.

    I’m sorry but how do I disable jQuery loaded by theme and use the default one ?

    Plugin Contributor Max Bond

    (@max-bond)

    Hm…
    First you need to check theme options.
    Some themes provide option to choose jQuery version.
    If there is no such an option… in this case you need to edit theme’s files directly. Locate wp_enqueue_script() function which loads jquery-1.6.4.min.js file. Start searching from functions.php file. When you’ll find the right function, disable it by commenting the line (use double slash – // int the line beginning). If you need to comment more then one line use /* in the beginning of comment block and */ at the end.

    I didn’t find anything in the theme options, I’ve found a folder named “js” in my theme which has this 3 files: jtwt.js , jquery.nivo.slider.pack.js , jquery-1.6.4.min.js and a folder named colorbox.

    Plugin Contributor Max Bond

    (@max-bond)

    Search functions.php file for any refrences of jquery-1.6.4.min.js
    If not found in functions.php continue to search in other files.

    I found this in the header:

    <?php if(is_singular()) wp_enqueue_script('comment-reply'); ?>
    <?php wp_deregister_script('jquery'); ?>
    <?php wp_enqueue_script('jquery', get_template_directory_uri() . '/js/jquery-1.6.4.min.js'); ?>
    <?php wp_enqueue_script('jtwt', get_template_directory_uri() . '/js/jtwt.js'); ?>
    <?php wp_enqueue_script('jquery.nivo.slider', get_template_directory_uri() . '/js/jquery.nivo.slider.pack.js'); ?>
    <?php wp_enqueue_script('jquery.colorbox', get_bloginfo('template_directory'). '/js/colorbox/jquery.colorbox-min.js'); ?>
    <?php wp_head(); ?>
    Plugin Contributor Max Bond

    (@max-bond)

    Good!

    Now make the change:

    <?php //wp_deregister_script('jquery'); ?>
    <?php //wp_enqueue_script('jquery', get_template_directory_uri() . '/js/jquery-1.6.4.min.js'); ?>
    <?php wp_enqueue_script('jquery'); ?>

    You need to comment two lines and add one.

    It’s working now, thank you so much for your help!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Plugin not working’ is closed to new replies.